Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

AuthenticationFailureEventListener: Authentication failure for user: 'admin' from xx.xx

avatar
Explorer

Hi All - We have tried to move Cloudera manager mysql to other disk , when we made changes and restarted cloudera-scm-server logs says nav database not found. we created the nav database in mysql and restarted now it says authenctication failure for admin user. Would you please advise why this is happening and how to fix.

Thanks in advance.

1 ACCEPTED SOLUTION

avatar
Master Guru

@IVenkatesh,

 

Cloudera Manager knows to which database server to connect based on what it sees in /etc/cloudera-scm-server/db.properties

We would not know which server should be used.  It sounds like you'll have to figure out what has changed since you tried "moving" mysql server.

 

If you used to have more users, try accessing each 'scm' database with a mysql client and see what rows exist in the USERS table. That might give you some clues.

View solution in original post

2 REPLIES 2

avatar
Explorer

I see the cloudera manager is starting afresh and able to login only with user=admin and pwd=admin.we have 2 mysql databases one has amon,hue,mysql,navm,navs,rman databases and second has hive,oozie,scm,sentry.

and /etc/cloudera-scm-server/db.properties is pointing to second mysql database which has hive,oozie,scm,sentry.

Does this need a change to first server ?

avatar
Master Guru

@IVenkatesh,

 

Cloudera Manager knows to which database server to connect based on what it sees in /etc/cloudera-scm-server/db.properties

We would not know which server should be used.  It sounds like you'll have to figure out what has changed since you tried "moving" mysql server.

 

If you used to have more users, try accessing each 'scm' database with a mysql client and see what rows exist in the USERS table. That might give you some clues.