Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Beeline's output still shows the header even after setting --showheader=false

Solved Go to solution

Beeline's output still shows the header even after setting --showheader=false

Expert Contributor

In my beeline's output I am still able to see the header even after setting --showheader=false. Below is the query that I have execute.

beeline -u jdbc:hive2://10.241.1.85:10000/kaliamoorthya --silent=true --outputformat=csv2 --showheader=false -e 'select dns,tran_session from testtable group by dns,tran_session order by dns;'

Here is the output:

dns,tran_session
012345490,06-05-2016T0258
012365279,06-05-2016T0258
012365478,06-05-2016T0258
012365480,06-05-2016T0258
012365481,06-05-2016T0258
012365482,06-05-2016T0258
012365483,06-05-2016T0258
012365484,06-05-2016T0258
012365485,06-05-2016T0258
012365486,06-05-2016T0258
012365487,06-05-2016T0258
012365489,06-05-2016T0258
012365491,06-05-2016T0258
012365492,06-05-2016T0258
012365493,06-05-2016T0258
012365494,06-05-2016T0258
012365495,06-05-2016T0258
012365496,06-05-2016T0258
012365497,06-05-2016T0258
012365498,06-05-2016T0258
012365499,06-05-2016T0258
012365588,06-05-2016T0258

Any clue what is causing this?

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Beeline's output still shows the header even after setting --showheader=false

3 REPLIES 3

Re: Beeline's output still shows the header even after setting --showheader=false

Re: Beeline's output still shows the header even after setting --showheader=false

Expert Contributor

Do we have a workaround for this @Jitendra Yadav ?

Highlighted

Re: Beeline's output still shows the header even after setting --showheader=false

@Alex Raj Sorry, I don't see any workaround therefore you probably need to upgrade the hive version to 1.2.

Don't have an account?
Coming from Hortonworks? Activate your account here