Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Blank screen when opening the Cloudera Navigator Server URL (https://{management_node}:7187/login

Solved Go to solution

Blank screen when opening the Cloudera Navigator Server URL (https://{management_node}:7187/login

Contributor

Hi,

 

Wondering if someone could provide advice....

 

We have CDH 5.9.0 installed and being managed by CM, with a myriad of services configured, installed and running (including Zookeeper, HDFS, YARN, Hue, Hive, HS2, Impala, Sqoop2, HBase, Oozie, Sentry, Solr/Search, Spark and Cloudera Navigator).

 

When I open a Microsoft IE 11 web browser, point it at the CM URL (port 7180) and navigate to:

 

Cloudera Management Service -> Navigator Metadata Server -> Cloudera Navigator (from the top menu choice)

 

and try and open the Cloudera Navigator Server URL (https://{management_node}:7187/login) in a new IE browser tab, I receive a blank screen.

 

I have read the following Community Support posts:

 

http://community.cloudera.com/t5/Data-Discovery-Optimization/Cloudera-Navigator-Blank-Page-on-Intern...

 

 

And have enable the IE 11 "Enterprise Mode" using this URL (it was originally disabled in the IE 11 broswer):

 

https://answers.uillinois.edu/page.php?id=59740

 

 

I can now see the "Enterprise Mode" option under the MS IE 11 "Tools" menubar, but I still cannot see any content on the Cloudera Navigator page.

 

I have executed "tree -a" and "ps -afe" command as follows to show the process tree strcture for Navigator:

 

[root@{obfuscated_management_node_name}]#  tree -a/var/run/cloudera-scm-agent/process/1297-cloudera-mgmt-NAVIGATOR

 

1297-cloudera-mgmt-NAVIGATOR

├── clouderaManagerVersion.txt

├── cloudera-monitor.properties

├── cloudera-navigator-cm-auth.properties

├── cloudera-navigator.properties

├── cloudera-stack-monitor.properties

├── db.navigator.properties

├── event-filter-rules.json

├── log4j.properties

├── logs

│   ├── stderr.log

│   └── stdout.log

├── monitoringEntities.properties

├── navigator.jaas.conf

├── navigator.keytab

├── service-metrics.properties

└── supervisor.conf

 

1 directory, 15 files

 

[root@{obfuscated_management_node_name}]#  ps -afe | grep 1297


clouder+ 10696 7187 0 Feb01 ? 00:06:58 /usr/java/jdk1.7.0_71/bin/java -server -XX:+UseConcMarkSweepGC -XX:+UseParNewGC -Dmgmt.log.file=mgmt-cmf-mgmt-NAVIGATOR-{obfuscated_fqdn_of_management_node}.log.out -Djava.awt.headless=true -Djava.net.preferIPv4Stack=true -Dnavigator.schema.dir=/usr/share/cmf/cloudera-navigator-audit-server/schema -Dnavigator.auditModels.dir=/usr/share/cmf/cloudera-navigator-audit-server/auditModels -Xms1073741824 -Xmx1073741824 -XX:+HeapDumpOnOutOfMemoryError -XX:HeapDumpPath=/tmp/mgmt_mgmt-NAVIGATOR-5a18597f006f273bd64dc317f86b2618_pid10696.hprof -XX:OnOutOfMemoryError=/usr/lib64/cmf/service/common/killparent.sh -cp /run/cloudera-scm-agent/process 1297-cloudera-mgmt-NAVIGATOR:/usr/share/java/mysql-connector-java.jar:/usr/share/cmf/lib/postgresql-9.0-801.jdbc4.jar:/usr/share/java/oracle-connector-java.jar:/usr/share/cmf/lib/plugins/event-publish-5.9.0-shaded.jar:/usr/share/cmf/lib/plugins/tt-instrumentation-5.9.0.jar:/usr/share/cmf/cloudera-navigator-audit-server/*: com.cloudera.navigator.NavigatorMain --conf-dir /run/cloudera-scm-agent/process/1297-cloudera-mgmt-NAVIGATOR

 

 

I have also confirmed port 7187 is open and listening:

 

[root@{obfuscated_management_node_name}#  netstat -lntup | grep LIST | grep 7187


     tcp 0 0 0.0.0.0:7187 0.0.0.0:* LISTEN 15276/java
     tcp 0 0 127.0.0.1:19001 0.0.0.0:* LISTEN 7187/python

 

 

 

Please help if you are out there Obi Wan Kenobi !

 

 

Thanks,

 

Damion.

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Blank screen when opening the Cloudera Navigator Server URL (https://{management_node}:7187/logi

Contributor

We have resolved this issue.  Turns out it was a compatibility issue in our wonderfull Internet Explorer browser.

1 REPLY 1

Re: Blank screen when opening the Cloudera Navigator Server URL (https://{management_node}:7187/logi

Contributor

We have resolved this issue.  Turns out it was a compatibility issue in our wonderfull Internet Explorer browser.