Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

CDH 5.9.1 HiveServer2 ignores bind host settings

New Contributor



It seems that it's no longer possible to bind HiveServer2 to a specific IP address - it only listens on

I've tried defining either the environment variable HIVE_SERVER2_THRIFT_BIND_HOST, or the property "" in hive-site.xml to an IP address, but it continues binding to a wildcard address only.

It successfully reads the HIVE_SERVER2_THRIFT_PORT variable, if defined just for testing purpose.

The webui host also binds to IP address at port 10002 successfully if configured so.

Isn't there any other new feature I missed to configure in this release to make the binding work? I have an old installation of CDH 5.4 there HiveServer2 is binding to an IP address without issues.

Has anybody faced the same?





New Contributor

Just upgraded to version 5.10.1 - the issue still persists. HiveServer2 continues listening only on address and further ignores HIVE_SERVER2_THRIFT_BIND_HOST env variable (as well as property).

What I'm trying to achieve (and which worked well in version 5.4) is to bind HiveServer2 to a concrete address only, e.g., as my server has several IP addresses and there are other services using port 10000 with another IP. So after CDH upgrade HiveServer2 could not start anymore ("address already in use") until I changed its port to another value.