Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

CDH installation: Failed to create HDFS directory /tmp



I am in the step of "Starting HDFS" installation, however, when it is about to be finished I get the following error:

"Creating HDFS /tmp/directory". Command aborted because of exception: Command timed-out after 90 seconds.

Directory /tmp does not currently exist.


How can I solve this problem?




Kind regards,


New Contributor

Hi. I also had this problem and I solved it.

Just open port 8022.

All namenodes try to connect to cloudera manager using this port.


Good luck



New Contributor
That worked after opening the port 8022 🙂

could you tell me how to open the port 8022 ? thank you very much



as a root run the below command to see if the port is listed there and listening . 

netstat -nlp

meantime check your firewalld status if its active and if you are ok try disabling it . 

could you let me know operating system that you are using ? 

New Contributor

I am having similar issue. I checked to see that firewalld is inactive. Port 8022 is listening as per netstat -nlp


I am using Cloudera installation wizard and on the Ssh login credentials page to select install options, I picked root password method


Any ideas what to check next?

New Contributor

Also note that hostname returns the correct FQDN but hostname -f returns "localhost" and not a proper name. That could be an issue right?

New Contributor
fixed hostname -f to return FQDN, still the same issue

New Contributor

I had a problem in my /etc/hosts file. Fixed that and now hostname -f is fine and I'm able to go past the issue with 8022 port.

Cautionary note: don't mess with existing lines in /etc/hosts file if you need to edit this file. Add to the file , don't update.


Could you post the full installer log for more digging . 


one thing i assume might be a permission issue .

did you kick off the installation as root ?


finally let me know if you are able to go to the 

hostname:50070 - Namenode UI
Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.