Support Questions

Find answers, ask questions, and share your expertise

CDP 7 placement rules dont work

New Contributor

Hi, trying to set placement rules as described in, but tasks still in default queue.

Also tried to enable tag-based authorization with the same result.

What could be wrong?


Cloudera Employee

Please share a screenshot of your placement rules

Cloudera Employee

Hello @Scout 

First, we need to understand we tried to enable tag-based policy only for Hive jobs because those jobs submitted by proxy user hive. After we enable the tab-bases policy the job submitted with hive user instead of proxy user


Step 1:

Enable application tag placement and whitelist hive

  1. In Cloudera Manager, select the YARN service.
  2. Click the Configuration tab.
  3. Search for ResourceManager. In the Filters pane, under Scope, select ResourceManager.
  4. In ResourceManager Advanced Configuration Snippet (Safety Valve) for yarn-site.xml add the following.
  5. Set these two yarn configurations:
  • yarn.resourcemanager.application-tag-based-placement.enable=true;
  • yarn.resourcemanager.application-tag-based-placement.username.whitelist=hive;


Step 2:

You need to check, and if not found, add several configuration properties to allow placement of the Hive workload on the Yarn queue manager.

  1. In Cloudera Manager, click Clusters > Hive on Tez> Configuration.
  2. Search for the Hive Service Advanced Configuration Snippet (Safety Valve) for hive-site.xml setting.
  3. In the Hive Service Advanced Configuration Snippet (Safety Valve) for hive-site.xml setting, click +.
  • In Name enter the property hive.server2.tez.initialize.default.sessions and in value enter false.
  • In Name enter the property hive.server2.tez.queue.access.check and in value enter true.
  • In Name enter the property hive.server2.tez.sessions.custom.queue.allowed and in value enter true.


Next you need to add placement rules as below:

Add placement rules >> This rule matches = hive_user >> Custom policy = <> (where you want to submit the job.


Note: Order of policy also played vital role, please order properly to move the job in aligned queue.

New Contributor

Hello, sorry for a big delay.

That solution didn't worked for me.

I've set all parameters in Yarn and Hive-on-Tez, but test user going to default query anyway.

Maybe I can check logs or something for that placement rules?


Community Manager

@Scout, Has any of the replies helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future.  


Vidya Sargur,
Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community: