Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

CDSW Kerberos and session error, Urgent!!

CDSW Kerberos and session error, Urgent!!

New Contributor

Hi All,

 

I have installed CDSW 1.3 successfully on:

  - EDH 5.11.1

  - CM 5.13

  - CDSW 1.3

  - 2 CDSW nodes, one master, one worker

 

Now they are experiencing the following problems:

  - Can't start CDSW session ( Phython, R, Scala ), error message "Whoops, there was an unexpected error.";

  - Can't get Kerberos authentication, error message "could not authenticate using provided Kerberos principal and password";

 

I've tried the following to troubleshoot:

  - command "kubectl config view", output:

    -> apiVersion: v1

    -> clusters:[]

    -> contexts:[]

    -> current-context:""

    -> kind: Config

    -> preferences:{}

    -> users: []

 

  - Modified parameters “default_tgs_enctypes = aes256-cts aes128-cts rc4-hmac”, “default_tkt_enctypes = rc4-hmac aes256-cts aes128-cts” and “permitted_enctypes = aes256-cts aes128-cts rc4-hmac” to kbr5.conf according to this KB Article, then removed & regenerated authentication;

    -> modified kbr5.conf on all CDSW nodes;

    -> restarted CDSW service from CM;

    -> after modifying kbr5.conf, kinit failed with error message “kinit: configuration file does not specify default realm when parsing name”;

    -> the service took very long time over 10 minutes and the web still not ready;

    -> changed the kbr5.conf back to its original format, removed aes256 & aes128;

    -> kinit works after kbr5.conf changed;

    -> use klist -e and got a valid principal;

    -> CDSW service started normally;

 

After CDSW service started, I tried “cdsw validate”, there was no error detected. I tried to start a session ‘python’, ‘scala’ or ‘R’, got the following error message “Whoops, there was an unexpected error."

 

Tried to configure Kerberos using the same principal and password which works using kinit through command line, got an error “Could not authenticate using provided Kerberos principal and password”.

 

Thanks

2 REPLIES 2

Re: CDSW Kerberos and session error, Urgent!!

Guru
Suggest to scan through the output of:

journalctl -o cat -l

for any errors.

Also, what's the output of "cdsw status"?

Re: CDSW Kerberos and session error, Urgent!!

Contributor
The CDSW Session error most likely related to DNS issue. Did you add DNS wildcard entry?