Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

CM 5.5 failed to validate hue configuration with httpfs load balanced

SOLVED Go to solution

CM 5.5 failed to validate hue configuration with httpfs load balanced

Explorer

Hello

             we have deployed two httpfs in CDH 5.5.2 with CM 5.5.3 , and  we have balanced the 2 services   with an external loadbalancer, and populate in Cm => HDFS => scope = HttpFS the "httpfs Load Balancer" with loadbalancer:port. We tested it with curl and it's working like a charm.

 

After that in CM=> Hue , it's possible to choose the load balancer for browsing hdfs from hue, by the way, if it's selected,  the CM will give an error of "configuration error:null".

 

As workaround we used the safety valve to define the loadbalancer web url.

 

Any idea ? Do we have hit a bug of CM ?

 

 

 

Kind Regards

1 ACCEPTED SOLUTION

Accepted Solutions

Re: CM 5.5 failed to validate hue configuration with httpfs load balanced

Explorer

Workaround :  insert in the safety valve hue.ini in CM :ìthe follow rows :

 

[hadoop]
[[hdfs_clusters]]
[[[default]]]
webhdfs_url=http://loadbalancer_httpfs_server_fwdn_name:14000/webhdfs/v1/

1 REPLY 1

Re: CM 5.5 failed to validate hue configuration with httpfs load balanced

Explorer

Workaround :  insert in the safety valve hue.ini in CM :ìthe follow rows :

 

[hadoop]
[[hdfs_clusters]]
[[[default]]]
webhdfs_url=http://loadbalancer_httpfs_server_fwdn_name:14000/webhdfs/v1/