Support Questions
Find answers, ask questions, and share your expertise

CM don't show Impala queries

Solved Go to solution
Highlighted

CM don't show Impala queries

Contributor

The Cloudera Manager Impala service don't show the queries..

 

impala.png

 

 

 

 

In "Impala Best Practices", all charts shown "NO DATA".

 

 

chart library "Impala queries" can not be shown

impala2.png

 

 

 

 

The CDH & CM version is 5.4.0(installation by path C), Centos6.6

 

I have reinstalled the CM and all services, the problem still exists.

 

The CM TimeZone is Error. But in the OS, the time zone is correct. 

I don't know how to fix that.

 

------------

 

Finally, I fixed the hwclock time, the probem has been solved.

 

 

 

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: CM don't show Impala queries

Contributor
Yes.
Our cluster using puppet to sync the time.
And it sync a wrong time every 10 mins.(it will overwirte '/etc/localtime')
 
Finally, I turned off the puppet time syncronization, and overwrite the '/etc/localtime' to a correct timezone file.
 
Then the CM impala service will show the queries.
And Impala Best Practices Charts worked well too.

View solution in original post

3 REPLIES 3

Re: CM don't show Impala queries

Community Manager

Sartner,

 

Just to clarify, the correction of the hwclock time resolved all your issues from your post?


Cy Jervis, Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:
Community Guidelines
How to use the forum
Highlighted

Re: CM don't show Impala queries

Contributor
Yes.
Our cluster using puppet to sync the time.
And it sync a wrong time every 10 mins.(it will overwirte '/etc/localtime')
 
Finally, I turned off the puppet time syncronization, and overwrite the '/etc/localtime' to a correct timezone file.
 
Then the CM impala service will show the queries.
And Impala Best Practices Charts worked well too.

View solution in original post

Highlighted

Re: CM don't show Impala queries

Community Manager

Great! Thanks for sharing the solution. :)


Cy Jervis, Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:
Community Guidelines
How to use the forum
Don't have an account?