Support Questions
Find answers, ask questions, and share your expertise

Cannot enable hiveserver interactive

Solved Go to solution

Cannot enable hiveserver interactive

Explorer

I tried to move my HSI to another node on my production cluster without stopping hiveserver or metastore components, so i disabled it first from ambari UI (no problem at this stage).
Now when i try to enable Interactive Query it shows a pop with an error message : You cannot enable Interactive Query now because Interactive Query is in the process of being disabled. This may take a few minutes. Try again later.

 

enirys_0-1618922965913.png

Nothing in ambari logs neither in hive-interactive logs because it was uninstalled.

 

Any advise please ?

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Cannot enable hiveserver interactive

Cloudera Employee

@enirys This issue occurs when the request status in Ambari DB is not matching the current status of LLAP. Due to this, we can't enable Interactive Query.

1) Kindly check for the status in the Ambari DB using the below command:

"select status, last_execution_status from requestschedule 
where status='SCHEDULED' OR status='IN_PROGRESS'"

2) To change this, run the following and change status form requestschedule table to 'COMPLETED'.

update requestschedule set status='COMPLETED' where status='SCHEDULED'

Reference article: 

https://community.cloudera.com/t5/Customer/ERROR-quot-You-cannot-enable-Interactive-Query-now-becaus... 

 

Please accept as solution if my above update helps you.

 

Thanks!

View solution in original post

2 REPLIES 2

Re: Cannot enable hiveserver interactive

Cloudera Employee

@enirys This issue occurs when the request status in Ambari DB is not matching the current status of LLAP. Due to this, we can't enable Interactive Query.

1) Kindly check for the status in the Ambari DB using the below command:

"select status, last_execution_status from requestschedule 
where status='SCHEDULED' OR status='IN_PROGRESS'"

2) To change this, run the following and change status form requestschedule table to 'COMPLETED'.

update requestschedule set status='COMPLETED' where status='SCHEDULED'

Reference article: 

https://community.cloudera.com/t5/Customer/ERROR-quot-You-cannot-enable-Interactive-Query-now-becaus... 

 

Please accept as solution if my above update helps you.

 

Thanks!

View solution in original post

Re: Cannot enable hiveserver interactive

Explorer

@shobikas

 

Thank you for your reply, you are right about ambari DB. i had two requests in "SCHEDULED" status.

ambari_db.png

 

I just updated the status to "COMPLETED" then restart ambari to get it working.

Thank you so much for your help