Support Questions
Find answers, ask questions, and share your expertise

Cannot run YARN on Ozone in CDP 7.1.1

Highlighted

Cannot run YARN on Ozone in CDP 7.1.1

Explorer

Hello

 

I wanted to test Ozone so I installed CDP 7.1.1 and setup OzoneFS according to the not-so-accurate documentation.

 

The FS itself seems to work. I am able to use hdfs commands to see files in ozone, create directories and upload local files. However, YARN does not work so well with Ozone.

If I try to create jobHistory directory or install MapReduce framework jars from the Yarn CM Menu then it fails and says it does not recognize the OzoneFS jars. I get:

java.lang.RuntimeException: java.lang.ClassNotFoundException: Class org.apache.hadoop.fs.ozone.OzoneFileSystem not found

 I tried adding the jar (hadoop-ozone-filesystem-lib-current-0.5.0.7.1.1.0-565.jar) to MR application classpath and YARN application classpath. I also tried to add as the value of mapreduce.application.classpath in mapred-site.xml,

But none of them made it recognize the class and work.

 

Did anyone have success running YARN over Ozone ? What am I missing ?

 

Thank you

 

Guy

1 REPLY 1

Re: Cannot run YARN on Ozone in CDP 7.1.1

Expert Contributor

Can you verify one, whether did you followed all the steps listed in the documentation?

https://docs.cloudera.com/runtime/7.1.1/ozone-storing-data/topics/ozone-setting-up-ozonefs.html