Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Cannot start cloudera-scm-agent.

avatar
Explorer

I am trying install cloudera 5.16.2(single mode). In cluster instalasion  i am get this error.

 

Spoiler
Spoiler


/tmp/scm_prepare_node.ZzLnmqNE
using SSH_CLIENT to get the SCM hostname: 10.0.0.4 34302 22
opening logging file descriptor
Starting installation script...
Acquiring installation lock...
BEGIN flock 4
END (0)
Detecting root privileges...
effective UID is 0
Detecting distribution...
BEGIN grep Tikanga /etc/redhat-release
END (1)
BEGIN grep 'CentOS release 5' /etc/redhat-release
END (1)
BEGIN grep 'Scientific Linux release 5' /etc/redhat-release
END (1)
BEGIN grep Santiago /etc/redhat-release
END (1)
BEGIN grep 'CentOS Linux release 6' /etc/redhat-release
END (1)
BEGIN grep 'CentOS release 6' /etc/redhat-release
END (1)
BEGIN grep 'Scientific Linux release 6' /etc/redhat-release
END (1)
BEGIN grep Maipo /etc/redhat-release
END (1)
BEGIN grep 'CentOS Linux release 7' /etc/redhat-release
CentOS Linux release 7.5.1804 (Core)
END (0)
/etc/redhat-release ==> CentOS 7
Detecting Cloudera Manager Server...
BEGIN host -t PTR 10.0.0.4
Host 4.0.0.10.in-addr.arpa. not found: 3(NXDOMAIN)
END (1)
BEGIN which python
/usr/bin/python
END (0)
BEGIN python -c 'import socket; import sys; s = socket.socket(socket.AF_INET); s.settimeout(5.0); s.connect((sys.argv[1], int(sys.argv[2]))); s.close();' 10.0.0.4 7182
END (0)
BEGIN which wget
/usr/bin/wget
END (0)
BEGIN wget -qO- -T 1 -t 1 http://169.254.169.254/latest/meta-data/public-hostname && /bin/echo
END (8)
Installing package repositories...
validating format of repository file /tmp/scm_prepare_node.ZzLnmqNE/repos/rhel7/cloudera-manager.repo
installing repository file /tmp/scm_prepare_node.ZzLnmqNE/repos/rhel7/cloudera-manager.repo
repository file /tmp/scm_prepare_node.ZzLnmqNE/repos/rhel7/cloudera-manager.repo installed
Refreshing package metadata...
BEGIN yum --disablerepo=* --enablerepo=cloudera* clean all
Loaded plugins: fastestmirror, langpacks
Cleaning repos: cloudera-manager
Cleaning up everything
Maybe you want: rm -rf /var/cache/yum, to also free up space taken by orphaned data from disabled or removed repos
END (0)
BEGIN rm -Rf /var/cache/yum/x86_64
END (0)
BEGIN yum --disablerepo=* --enablerepo=cloudera* makecache
Loaded plugins: fastestmirror, langpacks
Determining fastest mirrors
Metadata Cache Created
END (0)
Installing cloudera-manager-agent package...
BEGIN yum --disablerepo=* --enablerepo=cloudera* list installed cloudera-manager-agent
Loaded plugins: fastestmirror, langpacks
Installed Packages
cloudera-manager-agent.x86_64 5.16.2-1.cm5162.p0.7.el7 @Cloudera-manager
END (0)
BEGIN echo oracle-j2sdk1.7 cloudera-manager-agent cloudera-manager-daemons | grep cloudera-manager-agent
oracle-j2sdk1.7 cloudera-manager-agent cloudera-manager-daemons
END (0)
BEGIN yum --disablerepo=* --enablerepo=cloudera* info cloudera-manager-agent
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
Installed Packages
Name : cloudera-manager-agent
Arch : x86_64
Version : 5.16.2
Release : 1.cm5162.p0.7.el7
Size : 76 M
Repo : installed
From repo : cloudera-manager
Summary : The Cloudera Manager Agent
URL : http://www.cloudera.com
License : Proprietary
Description : The Cloudera Manager Agent.
:
: The Agent is deployed to machines running services managed by
: Cloudera Manager.

END (0)
Version : 5.16.2
Release : 1.cm5162.p0.7.el7
BEGIN yum -y install cloudera-manager-agent
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* epel: mirror.umd.edu
http://csc.mcs.sdsmt.edu/epel/7/x86_64/repodata/2315a785ec9b893a28d85b3782ba8a1bb742b8d07449f7040b22...: [Errno 12] Timeout on http://csc.mcs.sdsmt.edu/epel/7/x86_64/repodata/2315a785ec9b893a28d85b3782ba8a1bb742b8d07449f7040b22...: (28, 'Operation too slow. Less than 1000 bytes/sec transferred the last 30 seconds')
Trying other mirror.
Package cloudera-manager-agent-5.16.2-1.cm5162.p0.7.el7.x86_64 already installed and latest version
Nothing to do
END (0)
remote package cloudera-manager-agent installed
Installing cloudera-manager-daemons package...
BEGIN yum --disablerepo=* --enablerepo=cloudera* list installed cloudera-manager-daemons
Loaded plugins: fastestmirror, langpacks
Installed Packages
cloudera-manager-daemons.x86_64 5.16.2-1.cm5162.p0.7.el7 @Cloudera-manager
END (0)
BEGIN echo oracle-j2sdk1.7 cloudera-manager-agent cloudera-manager-daemons | grep cloudera-manager-daemons
oracle-j2sdk1.7 cloudera-manager-agent cloudera-manager-daemons
END (0)
BEGIN yum --disablerepo=* --enablerepo=cloudera* info cloudera-manager-daemons
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
Installed Packages
Name : cloudera-manager-daemons
Arch : x86_64
Version : 5.16.2
Release : 1.cm5162.p0.7.el7
Size : 931 M
Repo : installed
From repo : cloudera-manager
Summary : Provides daemons for monitoring Hadoop and related tools.
URL : http://www.cloudera.com
License : Proprietary
Description : This package includes daemons for monitoring and managing Hadoop.

END (0)
Version : 5.16.2
Release : 1.cm5162.p0.7.el7
BEGIN yum -y install cloudera-manager-daemons
Loaded plugins: fastestmirror, langpacks
Loading mirror speeds from cached hostfile
* epel: iad.mirror.rackspace.com
Package cloudera-manager-daemons-5.16.2-1.cm5162.p0.7.el7.x86_64 already installed and latest version
Nothing to do
END (0)
remote package cloudera-manager-daemons installed
Installing Unlimited Strength Encryption policy files.
Installation not requested. Step will be skipped.
Configuring Cloudera Manager Agent...
BEGIN grep server_host=10.0.0.4 /etc/cloudera-scm-agent/config.ini
END (1)
BEGIN cp /etc/cloudera-scm-agent/config.ini /etc/cloudera-scm-agent/config.ini.orig
END (0)
BEGIN sed -e 's/\(server_host=\).*/\110.0.0.4/' -i /etc/cloudera-scm-agent/config.ini
END (0)
scm agent configured
BEGIN sed -e 's/#\(USER=.*\)/\1/' -i /etc/default/cloudera-scm-agent
END (0)
Starting Cloudera Manager Agent...
BEGIN /sbin/service cloudera-scm-agent status
● cloudera-scm-agent.service - LSB: Cloudera SCM Agent
Loaded: loaded (/etc/rc.d/init.d/cloudera-scm-agent; bad; vendor preset: disabled)
Active: failed (Result: exit-code) since Mon 2019-10-14 01:18:43 WIB; 9h ago
Docs: man:systemd-sysv-generator(8)
Process: 32808 ExecStart=/etc/rc.d/init.d/cloudera-scm-agent start (code=exited, status=1/FAILURE)

Oct 14 01:18:43 xxx.xxx.xxx.xxxsystemd[1]: Starting LSB: Cloudera SCM Agent...
Oct 14 01:18:43 xxx.xxx.xxx.xxx su[32826]: (to cloudera-scm) root on none
Oct 14 01:18:43 xxx.xxx.xxx.xxx cloudera-scm-agent[32808]: Starting cloudera-scm-agent: bash: /var/log/cloudera-scm-agent/cloudera-scm-agent.out: Permission denied
Oct 14 01:18:43 xxx.xxx.xxx.xxx cloudera-scm-agent[32808]: [FAILED]
Oct 14 01:18:43 xxx.xxx.xxx.xxx systemd[1]: cloudera-scm-agent.service: control process exited, code=exited status=1
Oct 14 01:18:43 xxx.xxx.xxx.xxx systemd[1]: Failed to start LSB: Cloudera SCM Agent.
Oct 14 01:18:43 xxx.xxx.xxx.xxx systemd[1]: Unit cloudera-scm-agent.service entered failed state.
Oct 14 01:18:43 xxx.xxx.xxx.xxx systemd[1]: cloudera-scm-agent.service failed.
END (3)
BEGIN /sbin/service cloudera-scm-agent start
Starting cloudera-scm-agent (via systemctl): Job for cloudera-scm-agent.service failed because the control process exited with error code. See "systemctl status cloudera-scm-agent.service" and "journalctl -xe" for details.
[FAILED]
END (1)
agent logs:
BEGIN tail -n 50 /var/log/cloudera-scm-agent//cloudera-scm-agent.out | sed 's/^/>>/'
>>[14/Oct/2019 00:14:10 +0000] 26295 MainThread agent INFO SCM Agent Version: 5.16.2
>>[14/Oct/2019 00:14:10 +0000] 26295 MainThread agent WARNING Expected mode 0751 for /run/cloudera-scm-agent but was 0755
>>[14/Oct/2019 00:14:10 +0000] 26295 MainThread agent INFO Re-using pre-existing directory: /run/cloudera-scm-agent
>>[14/Oct/2019 00:14:10 +0000] 26295 MainThread agent INFO SCM Agent Version: 5.16.2
>>[14/Oct/2019 00:14:10 +0000] 26295 MainThread agent WARNING Expected mode 0751 for /run/cloudera-scm-agent but was 0755
>>[14/Oct/2019 00:14:10 +0000] 26295 MainThread agent INFO Re-using pre-existing directory: /run/cloudera-scm-agent
END (0)
BEGIN tail -n 50 /var/log/cloudera-scm-agent//cloudera-scm-agent.log | sed 's/^/>>/'
>> verbose=self.__verbose
>> File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/supervisor-3.0-py2.7.egg/supervisor/xmlrpc.py", line 470, in request
>> '' )
>>ProtocolError: <ProtocolError for 127.0.0.1/RPC2: 401 Unauthorized>
>>[14/Oct/2019 00:14:14 +0000] 26309 MainThread agent INFO Trying to connect to newly launched supervisor (Attempt 3)
>>[14/Oct/2019 00:14:14 +0000] 26309 MainThread agent ERROR Failed! trying again in 1 second(s)
>>Traceback (most recent call last):
>> File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.16.2-py2.7.egg/cmf/agent.py", line 2271, in connect_to_new_supervisor
>> self.get_supervisor_process_info()
>> File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.16.2-py2.7.egg/cmf/agent.py", line 2291, in get_supervisor_process_info
>> self.identifier = self.supervisor_client.supervisor.getIdentification()
>> File "/usr/lib64/python2.7/xmlrpclib.py", line 1233, in __call__
>> return self.__send(self.__name, args)
>> File "/usr/lib64/python2.7/xmlrpclib.py", line 1591, in __request
>> verbose=self.__verbose
>> File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/supervisor-3.0-py2.7.egg/supervisor/xmlrpc.py", line 470, in request
>> '' )
>>ProtocolError: <ProtocolError for 127.0.0.1/RPC2: 401 Unauthorized>
>>[14/Oct/2019 00:14:15 +0000] 26309 MainThread agent INFO Trying to connect to newly launched supervisor (Attempt 4)
>>[14/Oct/2019 00:14:15 +0000] 26309 MainThread agent ERROR Failed! trying again in 1 second(s)
>>Traceback (most recent call last):
>> File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.16.2-py2.7.egg/cmf/agent.py", line 2271, in connect_to_new_supervisor
>> self.get_supervisor_process_info()
>> File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/cmf-5.16.2-py2.7.egg/cmf/agent.py", line 2291, in get_supervisor_process_info
>> self.identifier = self.supervisor_client.supervisor.getIdentification()
>> File "/usr/lib64/python2.7/xmlrpclib.py", line 1233, in __call__
>> return self.__send(self.__name, args)
>> File "/usr/lib64/python2.7/xmlrpclib.py", line 1591, in __request
>> verbose=self.__verbose
>> File "/usr/lib64/cmf/agent/build/env/lib/python2.7/site-packages/supervisor-3.0-py2.7.egg/supervisor/xmlrpc.py", line 470, in request
>> '' )

1 ACCEPTED SOLUTION

avatar
Explorer

Fixed After Reboot Machine. And Re-Install Cloudera

View solution in original post

1 REPLY 1

avatar
Explorer

Fixed After Reboot Machine. And Re-Install Cloudera