Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Cloubreak installation fails

Solved Go to solution
Highlighted

Cloubreak installation fails

Explorer

Hey,

i am currently evaluating using cloudbreak to deploy a HDP cluster. However when i try do deploy a cluster with cloudbreak the following error occurs:

Infrastructure creation failed. Reason: Failed to create the stack for CloudContext{id=3, name='marius1', platform='StringType{value='OPENSTACK'}', owner='4a7f9d4b-e68d-4a4b-ae00-5dcd9cf64b8c'} due to: Resource CREATE failed: BadRequest: resources.router_gateway: Invalid input for external_gateway_info. Reason: 'None' is not a valid UUID. Neutron server returns request_ids: ['req-69341fcc-ec4b-4576-b694-cbd0cf44a007']

Were are using Openstack Newton which is not officially supported, however i would like to know if this is version problem or a config problem. We do not have a free floating ip pool (only one per project allowed) so created a network using a subnet 192.168.0.0/24 and with no floating ip pool. This results into the shown error.

Cheers

Marius

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Cloubreak installation fails

Expert Contributor

Hi,

It does not seem to related to the version of OpenStack.

It looks like that OS::Neutron::Router creation failed. Resource creation defined here: https://github.com/sequenceiq/cloudbreak/blob/master/cloud-openstack/src/main/resources/templates/op... .

Floating IP pool is not created by Cloudbreak we just use that id what you specify during network creation: https://github.com/sequenceiq/cloudbreak/blob/master/cloud-openstack/src/main/resources/templates/op...

May I ask you to try to deploy into an existing subnet. So create a network and a subnet manually and specify the network/subnet and floating pool ids when you create a network. Please see attached screenshot.

15054-screen-shot-2017-05-04-at-150243.png

Thanks,

Attila

View solution in original post

3 REPLIES 3
Highlighted

Re: Cloubreak installation fails

Expert Contributor

Hi,

It does not seem to related to the version of OpenStack.

It looks like that OS::Neutron::Router creation failed. Resource creation defined here: https://github.com/sequenceiq/cloudbreak/blob/master/cloud-openstack/src/main/resources/templates/op... .

Floating IP pool is not created by Cloudbreak we just use that id what you specify during network creation: https://github.com/sequenceiq/cloudbreak/blob/master/cloud-openstack/src/main/resources/templates/op...

May I ask you to try to deploy into an existing subnet. So create a network and a subnet manually and specify the network/subnet and floating pool ids when you create a network. Please see attached screenshot.

15054-screen-shot-2017-05-04-at-150243.png

Thanks,

Attila

View solution in original post

Highlighted

Re: Cloubreak installation fails

Explorer

Did that and it worked. Thanks a lot.

Re: Cloubreak installation fails

Expert Contributor

hi @Marius Dieckmann, if you think that the answer was useful, then you might consider to accept it :). Thanks.

Don't have an account?
Coming from Hortonworks? Activate your account here