Support Questions

Find answers, ask questions, and share your expertise

Cloud break

New Contributor

I am trying to implement cloud break in our environment and am using the latest version.

Cloudbreak Deployer: 2.7.0

I can access the internet to download dependencies through proxy but the public docker hub is not whitelisted.

1. I tried to edit the docker-compose file to download from our private registry, the cbd pull command successfully downloads the images but when I do a cbd start it detects the config has been edited and

[WARN] docker-compose.yml already exists, BUT generate would create a DIFFERENT one!

[WARN] please regenerate it: cbd regenerate

[WARN] Please check the expected config changes with: cbd doctor

2. I download the images and retagged to match the ones in the docker-compose.yml it still tries to pull the images from docker public registry.

cbd version : 2.7.0

docker version: Client: Version: 17.12.1-ce

Is allowing access to public docker-hub my only option?

@rkovacs

@smishra

@bthiyagarajan

@Chris Gambino

Thank you for your help in advance!.

1 ACCEPTED SOLUTION

Expert Contributor

Hi @NaveenKrishna Murakonda,

I think you should try to set a registry mirror for your docker daemon:

https://docs.docker.com/registry/recipes/mirror/

Other option is to override the default docker image name's generated by cbd by editing your Profile file. To show all the environmant option you can use

cbd env show

The relevant environment variables for you (and also you can find the TAG ones to further customize):

DOCKER_IMAGE_CLOUDBREAK = Cloudbreak Docker image name [hortonworks/cloudbreak]
DOCKER_IMAGE_CLOUDBREAK_WEB = Web UI Docker image name [hortonworks/hdc-web]
DOCKER_IMAGE_CLOUDBREAK_AUTH = Authentication service Docker image name [hortonworks/hdc-auth]
DOCKER_IMAGE_CLOUDBREAK_PERISCOPE = Autoscale Docker image name [hortonworks/cloudbreak-autoscale]
DOCKER_IMAGE_CBD_SMARTSENSE = SmartSense Docker image name [hortonworks/cbd-smartsense]

I hope one of this can solve your issue.

View solution in original post

3 REPLIES 3

Expert Contributor

Hi @NaveenKrishna Murakonda,

I think you should try to set a registry mirror for your docker daemon:

https://docs.docker.com/registry/recipes/mirror/

Other option is to override the default docker image name's generated by cbd by editing your Profile file. To show all the environmant option you can use

cbd env show

The relevant environment variables for you (and also you can find the TAG ones to further customize):

DOCKER_IMAGE_CLOUDBREAK = Cloudbreak Docker image name [hortonworks/cloudbreak]
DOCKER_IMAGE_CLOUDBREAK_WEB = Web UI Docker image name [hortonworks/hdc-web]
DOCKER_IMAGE_CLOUDBREAK_AUTH = Authentication service Docker image name [hortonworks/hdc-auth]
DOCKER_IMAGE_CLOUDBREAK_PERISCOPE = Autoscale Docker image name [hortonworks/cloudbreak-autoscale]
DOCKER_IMAGE_CBD_SMARTSENSE = SmartSense Docker image name [hortonworks/cbd-smartsense]

I hope one of this can solve your issue.

New Contributor

@mmolnar

thank you for the info, the environment variables setup has helped me. I was able to execute the setup and continue with cbd start.

I have been using private ip and setup is hosted in aws and cbd start gives me credentials to login to the ui. I am currently unable to access the url, can you help with the ports that needs to be enabled or security group additions other than 443 to be able to access the UI.

NOTE: not iptables or firewall on the system internally at the moment.

current containers and their ports:

cbreak_cloudbreak_1 /start_cloudbreak_app.sh bash Up 0.0.0.0:8080->8080/tcp

cbreak_commondb_1 /bin/bash -c cd /var/lib/p ... Up “pvtip”:5432->5432/tcp

cbreak_consul_1 /bin/consul agent -server ... Up 8300/tcp, 8301/tcp, 8301/udp,

8302/tcp, 8302/udp,

0.0.0.0:8400->8400/tcp,

0.0.0.0:8500->8500/tcp, 8600/tcp,

“pvtip”:53->8600/udp

cbreak_haveged_1 haveged -F Up

cbreak_identity_1 /tmp/run.sh Up 0.0.0.0:8090->8080/tcp

cbreak_logrotate_1 /start.sh Up

cbreak_logsink_1 socat -u TCP-LISTEN:3333,r ... Up 0.0.0.0:32774->3333/tcp

cbreak_logspout_1 /bin/sh -c sleep 1; (ROUTE ... Exit 1

cbreak_mail_1 /bin/sh -c /opt/install.sh ... Up “privateip”:25 >25/tcp

cbreak_periscope_1 /start_periscope_app.sh Up 0.0.0.0:8085->8080/tcp

cbreak_registrator_1 /bin/registrator consul:// ... Up

cbreak_smartsense_1 /var/lib/smartsense/start- ... Exit 1

cbreak_sultans_1 /hortonworks-cloud-auth/st ... Up 0.0.0.0:3001->3000/tcp, 3001/tcp

cbreak_traefik_1 /entrypoint.sh --debug --w ... Up 0.0.0.0:443->443/tcp,

0.0.0.0:80->80/tcp,

“privateip”:8081->8080/tcp

cbreak_uluwatu_1 /hortonworks-cloud-web/sta ... Up 0.0.0.0:3000->3000/tcp

,

Expert Contributor

Hi @NaveenKrishna Murakonda,

Only 80,443 ports are necessary to be open. In your Profile file you should set the PUBLIC_IP and PRIVATE_IP variable according to your instance IP addresses and issue 'cbd restart' to take effect.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.