Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Connect to VM VNC server

avatar

Hi, I'm trying to connect to the VNC server I've created following this guide :

https://github.com/hortonworks-gallery/ambari-vnc-service#connect-to-vnc-server

I'm using VirtualBox for the HortonWorks sandbox, my desktop is windows and I'm using TightVNC to connect.

The problem is that I'm not sure which IP the VNC server holds. According to the guide it is the same IP that the VM holds(with display 1??) But pining from my desktop to the VM IP returns timeout (I got the IP by connecting through putty and ifconfig. This IP also appears on Ambari under hosts-> summary)

What am I doing wrong?

1 ACCEPTED SOLUTION

avatar
Master Guru
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
7 REPLIES 7

avatar
Explorer

@shimrit hoori

You can download putty and use the ssh option.

The port is 2222 and host is 127.0.0.1

or from the command line.

ssh root@127.0.0.1 -p 2222 should prompt for username and password . root/hadoop is the password. Then you are in.!

Hope this helps.

avatar

I know how to connect through putty but I need a graphical interface since I want to use Intellij or Eclipse

avatar
Super Guru

@shimrit hoori

Have you configured VNC on Hortonworks sandbox ? not sure if it by default comes with VNC -

in addition to what @Kuldeep Kulkarni mentioned

For vnc configuration on linux pls follow -http://www.tecmint.com/install-tightvnc-remote-desktop/

avatar

Maybe I've missed something but I was under the impression that Ambari takes care of all those settings and installations(at least that is what the guide is showing..)

avatar
Master Guru
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login

avatar

Pining to 127.0.0.1 will obviously work, trying to connect to it via TightVnc returns "No connection could be made because the target machine actively refused it" (I should mention that I'm not sure which port I should use - I tried 2222<the port that the putty connects to> and it returned unsupported protocol, 5901<the port that according to the guide should be forwarded , which I did under virtualbox-> vm settings -> network-> adapter1-> port forwarding ) and it returns "connection has been gracefully closed".

Switching from NAT to Bridge blocked putty from connection, I added second adapter(Bridge) so now my desktop can ping to that interface , but I can't add a port to forward to it (that option is blocked) and TightVnc returns connection refused.

avatar

Ok I've found the issue, at the beginning it didn't work since I didn't add the port 5901 to the forwarded ports, then I added it and restated the VM and forgot to start the VNC server from Ambari - that's why TightVNC returned "connection has been gracefully closed". Thanks!