Support Questions

Find answers, ask questions, and share your expertise
Celebrating as our community reaches 100,000 members! Thank you!

Connecting to VNC server VM using TightVNC

New Contributor


I set up a VNC server service in Ambari. And now I'm trying to create a VNC remote setup using TightVNC Viewer. But when I put in the IP address and display for eg: and try to set the remote connection, it says

"Error in TightVNC Viewer: No connection could be made because the target machine actively refused it." I tried changing the display:1 to port number 5901. But no help that way too. Is there anything I'm missing. please help.I needed to set up a working environment with eclipse and this has been giving me a hard time.


Master Mentor

@Veena N

Can you please check the following on the host where you have installed the VNC server.

1. In your Ambari Server Machine you have the correct package of "yum install tigervnc-server" installed as described in the following doc:

2. Please check if it tigervnc service is running fine or not?

# ps ax | grep tightvnc

3. Please use the "netstat" command to list the port opened by the "tigervnc-server" server.

# netstat -tnlpa | grep $PID_VNC

4. If the port is opened, then please check if the "iptables" (Firewall) is turned off?

# service iptables status
# service iptables stop

5. Double check the IPAddress of the host is correct becore connecting to the host. Use the following command to list the IP Addresses

# ifconfig


Ideally to access ambari server you do not need to install VNC server. You can simply make use of "SSH" (on windows putty based ssh access) to login to the VM host and then perform various operations. You can access the WebUI of the VM form your local machine.


New Contributor

Hi @Jay SenSharma

Thank you so much for the reply.

When i try to start the vnc server it gives me this error :

systemctl start vncserver@:<em>1</em>.service
Job for vncserver@:1.service failed. See 'systemctl status vncserver@:1.service' and 'journalctl -xn' for details.

Also should i run these in HDP sandbox docker container ?

When I run the below command : it gives me different process id even if I run the same command thrice in the shell. Is that how its supposed to be? I'm sorry , i'm so new to the Linux env that I feel I'm doing something wrong always!

ps ax | grep tightvnc

one more question Yes, how do I access the WebUI version from my local machine?i'm able to access Ambari and also the VNC server is started in Ambari services. Should I also install the tightVNC server seperately?

I'm trying to access the webUi from my local windows machine using tightVNC.Am I doing the right way?


Also I'm not seeing etho ip address ,

I'm using the ens32 ip listed below to access the sandbox .


New Contributor

Hi @Jay SenSharma

When i try to start the vnc server it gives me this error :

  1. systemctl start vncserver@:1.service
  2. Jobfor vncserver@:1.service failed.See 'systemctl status vncserver@:1.service'and'journalctl -xn'for details.