Support Questions
Find answers, ask questions, and share your expertise

Copy table operation fails on cluster

Explorer

I am trying to copy the writes after i took the snapshot to new cluster. the map reduce job fails with message

45772-screen-shot-2018-01-08-at-34536-pm.png

1 ACCEPTED SOLUTION

@prarthana basgod

As the official HBase book states:

You may need to find a sweet spot between a low number of RPCs and the memory used on the client and server. Setting the scanner caching higher will improve scanning performance most of the time, but setting it too high can have adverse effects as well: each call to next() will take longer as more data is fetched and needs to be transported to the client, and once you exceed the maximum heap the client process has available it may terminate with an OutOfMemoryException. When the time taken to transfer the rows to the client, or to process the data on the client, exceeds the configured scanner lease threshold, you will end up receiving a lease expired error, in the form of a ScannerTimeoutException being thrown.

So it would be better not to avoid the exception by the above configuration, but to set the caching of your Map side lower, enabling your mappers to process the required load into the pre-specified time interval.

Even you can increase

 <property>
 <name>hbase.regionserver.lease.period</name>
 <value>300000</value>
 </property>

Hope this helps you.

View solution in original post

1 REPLY 1

@prarthana basgod

As the official HBase book states:

You may need to find a sweet spot between a low number of RPCs and the memory used on the client and server. Setting the scanner caching higher will improve scanning performance most of the time, but setting it too high can have adverse effects as well: each call to next() will take longer as more data is fetched and needs to be transported to the client, and once you exceed the maximum heap the client process has available it may terminate with an OutOfMemoryException. When the time taken to transfer the rows to the client, or to process the data on the client, exceeds the configured scanner lease threshold, you will end up receiving a lease expired error, in the form of a ScannerTimeoutException being thrown.

So it would be better not to avoid the exception by the above configuration, but to set the caching of your Map side lower, enabling your mappers to process the required load into the pre-specified time interval.

Even you can increase

 <property>
 <name>hbase.regionserver.lease.period</name>
 <value>300000</value>
 </property>

Hope this helps you.

; ;