Support Questions
Find answers, ask questions, and share your expertise

Data Provenance not showing Nifi

Explorer

Hi, I am having trouble getting the data provenance displaying in a clustered environment in Nifi. I have set all the required access policies and still the data provenance is empty. Any suggestions at this point is very much appreciated. 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Data Provenance not showing Nifi

Super Guru

Two options.   Make sure your cluster is configured for data provenance.    Restart all your nodes.

 

Make sure you are running the latest version

 

If that doesn't work, open a support ticket with Cloudera.

View solution in original post

2 REPLIES 2

Re: Data Provenance not showing Nifi

Super Guru

Two options.   Make sure your cluster is configured for data provenance.    Restart all your nodes.

 

Make sure you are running the latest version

 

If that doesn't work, open a support ticket with Cloudera.

View solution in original post

Re: Data Provenance not showing Nifi

Explorer

Hi turns out it was a permissions issue, so I had created a policy to allow the user to view the data provenance inside the Process Group but for that to work you need to add a global policy to allow that user to view the data provenance. Seems like a bit of a hack to me but thats what I had to do to get it working. Thanks for your help