Support Questions
Find answers, ask questions, and share your expertise

Datanode not starting: SIGTERM error

Solved Go to solution

Datanode not starting: SIGTERM error

Rising Star

Hello,

 

Does anyone has any clue about below error. Datanode is not coming up with this error in the logs.

We are on Cloudera Hadoop 6.3.0.

 

RECIEVED SIGNAL 15: SIGTERM

 

Thanks

snm1523

2 ACCEPTED SOLUTIONS

Accepted Solutions

Re: Datanode not starting: SIGTERM error

Rising Star

Thank you for the reply @smdas 

 

After looking at the privilege logs, found that the port was reported to be used. In reality it was not being used so possible some caching issue. We rebooted the server and were able to then restart the DN successfully.

 

Thanks

snm1523

View solution in original post

Re: Datanode not starting: SIGTERM error

Expert Contributor

Hello @snm1523 

 

Glad to know the issue was resolved after a Node Reboot as the Port Binding was causing the DataNode exit, yet there were no Process holding the Port requiring a Reboot. Thanks for sharing the Cause & the Resolution as well.

 

If you have no further queries, Kindly mark the Post as Solved.

 

Thank You for using Cloudera Community !!!

 

- Smarak

View solution in original post

4 REPLIES 4

Re: Datanode not starting: SIGTERM error

Expert Contributor

Hello @snm1523 

 

Signal 15 tells us that something or someone intentionally killed the process. Check the Process StdOut & StdErr file for details. 

 

- Smarak

Re: Datanode not starting: SIGTERM error

Rising Star

Thank you for the reply @smdas 

 

After looking at the privilege logs, found that the port was reported to be used. In reality it was not being used so possible some caching issue. We rebooted the server and were able to then restart the DN successfully.

 

Thanks

snm1523

View solution in original post

Re: Datanode not starting: SIGTERM error

Expert Contributor

Hello @snm1523 

 

Glad to know the issue was resolved after a Node Reboot as the Port Binding was causing the DataNode exit, yet there were no Process holding the Port requiring a Reboot. Thanks for sharing the Cause & the Resolution as well.

 

If you have no further queries, Kindly mark the Post as Solved.

 

Thank You for using Cloudera Community !!!

 

- Smarak

View solution in original post

Re: Datanode not starting: SIGTERM error

Expert Contributor

Hello @snm1523 

 

As the Post was resolved, I am marking the Post as Solved. In future, Kindly mark the Post as Solved to ensure other Community Users can reference the Post for similar issues.

 

Thanks for using Cloudera Community. 

 

- Smarak