Support Questions
Find answers, ask questions, and share your expertise

Default password for Metron UI Version 0.4.0

New Contributor

I have installed apache metron version 0.4.0 using cloud installation, it created 10 nodes on ec2 and everything running fine but when i move to Metron Management UI it asks me for the password. I tried "Metron/Metron", "metron/metron", "admin/admin" etc but still unable to login. I tried metron user guides to find default password for metron UI but not able to find any document that gives or guides to set default password for metron.

Is there anyone who tried this? Can anyone help me for default password for metron UI.

5 REPLIES 5

Super Collaborator

Hey @Nilesh Shaikh, you will need to setup Spring Security and build the user credentials for Metron REST service,a s documented here.

As a quick workaround, you can try the following:

a) Login to Ambari UI -> Metron -> Configs -> Advanced -> Advanced metron-env. And ensure that the "Active Spring profiles" parameter is set to the value "dev". Then restart Metron REST service.

b) Now, you can fire up the Metron Management UI (http://node1:4200) and use the credentials "admin/password".

HTH,

Anand

New Contributor

Thank you @asubramanian for your reply. I already tried your quick workaround suggestion provided at this link -

https://community.hortonworks.com/questions/106135/need-password-for-apache-metron-ui-of-04-version....

I changed "Active Spring profiles" parameter to value "dev", initially it was blank. But after changing this parameter Metron REST service goes down and never come up. Multiple time i restarted all metron services but no luck and still not able to login with credentials "admin/password".

Also i am wondering is that if cloud installation do all setup then why it leaves spring security?

Thank you for giving me your time.

Super Collaborator

Hey @Nilesh Shaikh, can you tell me the error you are seeing when the Metron REST service fails to start? (You can see the error log by clicking on 'ops' in the Ambari UI, and then drilling down into the operation).

I have earlier built Metron 0.4.0 on a 12-node openstack environment using Ambari + Mpack installation and was able to get both Metron REST and the Management UI working successfully.

These were the parameters I specified when installing the Metron service (under Advanced -> Advanced metron-env)

Metron JDBC Driver = org.h2.Driver
Metron JDBC password = root
Metron JDBC platform = h2
Metron JDBC URL = jdbc:h2:file:~/metrondb
Metron JDBC username = root
Active Spring profiles = dev

On your environment, can you check the values of the above config parameters and then try restarting the service to see if it works?

Super Collaborator

@Nilesh Shaikh, did you get to try with the above config settings?

New Contributor

I found the following worked for me - [ Metron 0.4.0 for Amazon EC2 Install]:
--------------------------------------------------------------------------------------------------------------------
(These steps don't apply to modifying/configuring an existing Metron deployment. The steps include modifying the 0.4.0 code first [which was cloned from github] and then making a fresh new cloud install/deployment. If you found that "Metron REST" is failing to restart these steps might resolve the issue.)

1) After downloading the 0.4.0 code from github, update the metron-rest file that is in this location:

metron/metron-interface/metron-rest/src/main/scripts/metron-rest

on line 148 change "$0 start" to "$0 start $2"

This fix was found here


2) Run ./run.sh to kickoff the process of installing 0.4.0 to Amazon EC2 (as you normally would)


3) Then follow asubramanian steps:

" a) Login to Ambari UI -> Metron -> Configs -> Advanced -> Advanced metron-env. And ensure that the "Active Spring profiles" parameter is set to the value "dev". Then restart Metron REST service.


4) Restart all required process


5) After the processes have been restarted (and all statues are green) you can get to the Metron UI through Ambari with these steps:

Click on the "Services" tab (between "Dashboard" and "Hosts").
Click on "Metron" in the left panel.
Click on the "Quick Links" drop down menu. Then click on "Management UI"


6) "Fire up the Metron Management UI (http://node1:4200) and use the credentials "admin/password"