Support Questions
Find answers, ask questions, and share your expertise

Delete API for Custom created TypeDef in APache Atlas is not working

New Contributor

Hi All,

 

Thanks for reading my question. Please try to help me with your suggestions.

 

I have created my custom entity type def. Now I want to delete it.But not able to do. 

here is what I am trying to do

curl -i -X DELETE -H 'Content-Type: application/json' -u <user> 'http://host:21000/api/atlas/v2/types/typedefs/' -d @delete1.json

 

my json

{
"enumTypes": [],
"structTypes": [],
"traitTypes": [],
"classTypes": [{
"superTypes": ["DataSet"],
"hierarchicalMetaTypeName": "org.apache.atlas.typesystem.types.ClassType",
"typeName": "DELETEAPI",
"typeDescription": null,
"attributeDefinitions": [{
"name": "apiName",
"dataTypeName": "string",
"multiplicity": "required",
"isComposite": false,
"isUnique": false,
"isIndexable": true,
"reverseAttributeName": null
}
]
}]
}

 

 

response

HTTP/1.1 204 No Content
Date: Fri, 27 May 2022 15:27:22 GMT
Set-Cookie: ATLASSESSIONID=164i6cnhs29w61zq1nea7yxad;Path=/;HttpOnly
Expires: Thu, 01 Jan 1970 00:00:00 GMT
X-Frame-Options: DENY
X-Content-Type-Options: nosniff
X-XSS-Protection: 1; mode=block
Strict-Transport-Security: max-age=31536000; includeSubDomains
Content-Type: application/json; charset=UTF-8
requestId: b44c8ba1-5068-4a77-a993-dff419300251
X-Content-Type-Options: nosniff
Content-Security-Policy: default-src 'self'; script-src 'self' 'unsafe-inline' 'unsafe-eval' blob: data:; connect-src 'self'; img-src 'self' blob: data:; style-src 'self' 'unsafe-inline';font-src 'self' data:
Server: Apache Atlas

 

 

2 REPLIES 2

Cloudera Employee

Hello @VenkyBandaru ,

 

Could you please try the below curl command to delete the custom entity type def?

# curl -u <username>:<password> -X DELETE 'http://<hostname>:<port>/api/atlas/v2/types/typedefs' --header 'Content-Type: application/json' -d '{
"entityDefs": [
{
"name": "<custom type name>"
}
]
}'

 
Thanks,
Prashanth Vishnu

Moderator

@VenkyBandaru Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. Thanks!


Regards,

Diana Torres,
Community Moderator


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community:
; ;