Support Questions
Find answers, ask questions, and share your expertise
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Delete schema from Schema Registry

Solved Go to solution

Re: Delete schema from Schema Registry

New Contributor

Has any progress been made in developing a GUI to manage the Schema Registry ??? It appears many of us need the ability to Delete, Rename and otherwise manage the Schema's in the Schema Registry, I realize the brute force using SQL is a possibility but it is too error prone and clumsy which us unacceptable for a production environment. We really need a GUI that is fully supported to manage the Schema Registry entries so we can correct errors and Delete unwanted Schema's. It appears this question has not been updated in a long while so I wanted to see what is being done to resolve the issue. This doesn't sound like a heavy life for the technical team to add a little functionality to the existing Schema Registry GUI. Lets hear from the Hortonworks/Cloudera experts what the status is and when we might see a production ready solution.

Re: Delete schema from Schema Registry

New Contributor

Due the GUI still doesn't include the delete option, the workaround I'm using is to execute this curl comand:

CURL -X DELETE http://localhost:9090/api/v1/schemaregistry/schemas/<name>


Using the last version at this moment, hortonworks-registry-0.8.0-rc3, which includes a fix for ISSUE-574 that avoids error re-creating a previously deleted schema with the same name, works fine.


Hope it helps.



Don't have an account?
Coming from Hortonworks? Activate your account here