Support Questions
Find answers, ask questions, and share your expertise

Deploy metron on single VM (CentOS) error

Deploy metron on single VM (CentOS) error

Explorer

I am facing the below error when provisioning the Vagrant

TASK [ambari_master : Copy Elasticsearch MPack to Ambari Host] ***************** changed: [node1] TASK [ambari_master : Install Elasticsearch MPack on Ambari Host] ************** fatal: [node1]: FAILED! => {"changed": true, "cmd": "ambari-server install-mpack --mpack=/tmp/elasticsearch_mpack-0.5.1.0.tar.gz", "delta": "0:00:00.543065", "end": "2018-08-09 23:07:18.155082", "failed": true, "rc": 255, "start": "2018-08-09 23:07:17.612017", "stderr": "", "stdout": "Using python /usr/bin/python\nInstalling management pack\nERROR: Management pack elasticsearch-ambari.mpack-5.6.2 already installed!\nERROR: Exiting with exit code -1. \nREASON: Management pack elasticsearch-ambari.mpack-5.6.2 already installed!", "stdout_lines": ["Using python /usr/bin/python", "Installing management pack", "ERROR: Management pack elasticsearch-ambari.mpack-5.6.2 already installed!", "ERROR: Exiting with exit code -1. ", "REASON: Management pack elasticsearch-ambari.mpack-5.6.2 already installed!"], "warnings": []} to retry, use: --limit @/usr/metron/metron-deployment/development/centos6/ansible/playbook.retry PLAY RECAP ********************************************************************* node1 : ok=39 changed=7 unreachable=0 failed=1 Ansible failed to complete successfully. Any error output should be visible above. Please fix these errors and try again.

2 REPLIES 2

Re: Deploy metron on single VM (CentOS) error

Expert Contributor

Do you already have metron installed? And is your cluster already kerberized?


- Dennis Jaheruddin

If this answer helped, please mark it as 'solved' and/or if it is valuable for future readers please apply 'kudos'. Also check out my techincal portfolio at https://portfolio.jaheruddin.nl

Re: Deploy metron on single VM (CentOS) error

New Contributor

Having same issue. Were you able to fix this issue ?

,

I have same issue. Were you able to get around this ?