Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Disabling Kerberos

Solved Go to solution

Re: Disabling Kerberos

New Contributor

Hello Alessio,

 

I am facing the same problem could you please outline the steps you did for Yarn and Zookeeper.

 

Thanks

Deepak

Re: Disabling Kerberos

Explorer

The link provided is now broken. Is there an update to it?

Re: Disabling Kerberos

Explorer
 
Highlighted

Re: Disabling Kerberos

Community Manager

Try this one:

 

http://www.cloudera.com/documentation/manager/5-1-x/Configuring-Hadoop-Security-with-Cloudera-Manage...



Cy Jervis, Community Manager

Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Learn more about the Cloudera Community:
Community Guidelines
How to use the forum

Re: Disabling Kerberos

Explorer

Have the same problem, but after clean and reinstall cluster (using parcels). Error appears when oozie java action wrties to HDFS (runs from HUE). Earlier on this cluster was Kerberos, and I cleand all (I hope) directories from previous installation.

 

Here is a detailed message:

Failing Oozie Launcher, Main class [org.apache.oozie.action.hadoop.JavaMain], main() threw exception, java.io.IOException:
Failed on local exception: java.io.IOException: Server asks us to fall back to SIMPLE auth, but this client is configured to only allow secure connections.; 
Host Details : local host is: "hadoop-05.xxx.xx/172.19.x.xxx"; destination host is: "hadoop-02.xxx.xx":8020; 
org.apache.oozie.action.hadoop.JavaMainException: java.io.IOException: Failed on local exception: java.io.IOException:
Server asks us to fall back to SIMPLE auth, but this client is configured to only allow secure connections.;
Host Details : local host is: "hadoop-05.xxx.xx/172.19.x.xxx"; destination host is: "hadoop-02.xxx.xx":8020;

 

Re: Disabling Kerberos

Master Collaborator
I have a similar problem wanted to turn off Kerberos, so did everythin (turn auth to simple, data node ports etc etc).
Now the cluster does not use Kerberos, HDFS and Hive and Impala works fine, BUT THE OPTION FOR ENABLE KERBEROS IS STILL GREYED
Any thoughts?
T