Support Questions

Find answers, ask questions, and share your expertise
Check out our newest addition to the community, the Cloudera Data Analytics (CDA) group hub.

Download File from URL using invokeHTTP

I need to download a generated report from the web , The URL works fine when i use curl -L <'URL'> -o filename.

It does not get the file If this URL placed in attribute remoteURL in invokeHTTP . I tried both GET and POST using invokeHTTP.

Also tried to enclose URL in single quotes, having an option -L and all of them resulted in

"Routing to Failure due to exception: no protocol: "

Appreciate any help in getting this resolved.

3 REPLIES 3' -o author1.csv

What is changed in the url

This URL is give to the application for status request for report generation completion, can not be modified.

However My issue got resolved by setting "Always Output Response" to "true".

Thanks for looking in to it.

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.