Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

EBCDICRecordReader 1.0.0.2.1.6.1001-2

avatar
Explorer

Hi there!

I am trying to use this processor. I have found a very useful guide: https://docs.cloudera.com/cdf-datahub/7.2.18/mainframe-ebcdic-nifi/topics/cfm-create-mainframe-ebcdi...

I am following the same steps but I am encontering this error:
"Copybook Path" validated against #{hdfs.output.raw-input-files}TGSS/copybook.cbl is invalid because The specified resource do not exist or could not be accessed: [#{hdfs.output.raw-input-files}TGSS/copybook.cbl]
Is anybody having this issue?
How can I solve it?

Thanks in advance

6 REPLIES 6

avatar
Explorer

Of course I do have in HDFS in the route the copybook.cbl file.

avatar
Explorer

kelpye_0-1714128894102.png

 

avatar
Super Mentor

@kelpye 

While I am not familiar with this specific processor, maybe the following suggestions will help since the exception shared states that NiFi is unable to validate against the configured property value in the "CopybookPath" property :

1. The following string in your copybook path is a NiFi Parameter reference:

#{hdfs.output.raw-input-files}

When NiFi enables this processor it resolves the above the value configured to it in the parameter context list.  If you replace above with the absolute local path instead of using a parameter, does it validate?

2. Also keep in mind that all components executing on the canvas are executed as the NiFi service user and not as the authenticated user who added those components to the canvas.  So make sure that the NiFi service user is able to navigate the resolved path to your copybook.cbl file and has proper OS permissions to read that file.

Please help our community thrive. If you found any of the suggestions/solutions provided helped you with solving your issue or answering your question, please take a moment to login and click "Accept as Solution" on one or more of them that helped.

Thank you,
Matt

avatar
Explorer

Thanks for the replay and my apologies in  my late response. The first sugestion does not work, the error is not related to it. In any case I tried both and get the same error.
The second sugestion, it is right we firstly had problems to reaching the route but at the moment it is solved.

Anyway I still couldnt solve my problem.

avatar
Explorer

Hello Again Matt, 

I am going to give you more details about my problem.
I get this error: 

 

 

kelpye_2-1716362365779.png

I am putting in the NiFi directory my copy. It is structured like that :

 

kelpye_4-1716362594559.png

Then I have my cobol file. I have deleted all rows except 1 ( I have performed various test, full file, few raws ...) and I always ge the same error mentioned above.

This is the example of my cobol file with just one row:

kelpye_5-1716362800234.png

Do you have any clue what is happening?

 

Thank you very much for your help

 

avatar
Community Manager

@kelpye Has the reply helped resolve your issue? If so, please mark the appropriate reply as the solution, as it will make it easier for others to find the answer in the future. Thanks.


Regards,

Diana Torres,
Community Moderator


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community: