Support Questions

Find answers, ask questions, and share your expertise

ERROR manager.CatalogQueryManager: Failed to list databases com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure by using sqoop command

New Contributor

While using the command sqoop list-databases --connect jdbc:mysql://localhost --username root -P

getting an error as 

WARN: Establishing SSL connection without server's identity verification is not recommended. According to MySQL 5.5.45+, 5.6.26+ and 5.7.6+ requirements SSL connection must be established by default if explicit option isn't set. For compliance with existing applications not using SSL the verifyServerCertificate property is set to 'false'. You need either to explicitly disable SSL by setting useSSL=false, or set useSSL=true and provide truststore for server certificate verification.
21/05/22 22:33:18 ERROR manager.CatalogQueryManager: Failed to list databases
com.mysql.jdbc.exceptions.jdbc4.CommunicationsException: Communications link failure

 

Please help me to fix the above issue

1 REPLY 1

Expert Contributor

Hi,

It seems like your host from where you are running Sqoop command is not able to connect on the machine where your mysql is installed.

 

Kindly run the below command to check the connectivity.

## telnet <hostname> 3306

 

Note:- Hostname is the host where you have installed mysql database.

 

In the sqoop command i can see you have provided "localhost" double check it is the one where mysql database is installed.

 

Below is the command to get the full hostname of the host.

## hostname -f

Take a Tour of the Community
Don't have an account?
Your experience may be limited. Sign in to explore more.