Support Questions
Find answers, ask questions, and share your expertise

Enable Kerberos for Cluster

Solved Go to solution

Enable Kerberos for Cluster

Contributor

Dear all.

 

I'm trying to enable kerberos for cluster but I have got some errors below.

Anyone who know what is wrong ? 

 

/usr/share/cmf/bin/import_credentials.sh failed with exit code 127 and output of <<
+ export PATH=/usr/kerberos/bin:/usr/kerberos/sbin:/usr/lib/mit/sbin:/usr/sbin:/usr/lib/mit/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin
+ PATH=/usr/kerberos/bin:/usr/kerberos/sbin:/usr/lib/mit/sbin:/usr/sbin:/usr/lib/mit/bin:/usr/bin:/sbin:/usr/sbin:/bin:/usr/bin
+ KEYTAB_OUT=/var/run/cloudera-scm-server/cmf3579156749802764271.keytab
+ USER=cloudera-scm/admin@HBASE.ITSC.COM
+ PASSWD='REDACTED'
+ KVNO=1
+ SLEEP=0
+ RHEL_FILE=/etc/redhat-release
+ '[' -f /etc/redhat-release ']'
+ set +e
+ grep Tikanga /etc/redhat-release
+ '[' 1 -eq 0 ']'
+ '[' 0 -eq 0 ']'
+ grep 'CentOS release 5' /etc/redhat-release
+ '[' 1 -eq 0 ']'
+ '[' 0 -eq 0 ']'
+ grep 'Scientific Linux release 5' /etc/redhat-release
+ '[' 1 -eq 0 ']'
+ set -e
+ '[' -z /etc/krb5.conf ']'
+ echo 'Using custom config path '\''/etc/krb5.conf'\'', contents below:'
+ cat /etc/krb5.conf
+ IFS=' '
+ read -a ENC_ARR
+ for ENC in '"${ENC_ARR[@]}"'
+ ktutil
+ echo 'addent -password -p cloudera-scm/admin@HBASE.ITSC.COM -k 1 -e aes256-cts:normal'
+ '[' 0 -eq 1 ']'
+ echo 'REDACTED'
+ echo 'wkt /var/run/cloudera-scm-server/cmf3579156749802764271.keytab'
ktutil: relocation error: ktutil: symbol krb5_enctype_to_name, version k5crypto_3_MIT not defined in file libk5crypto.so.3 with link time reference

 

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Enable Kerberos for Cluster

Contributor

The problem was PATH for the ktutil. 

solved.

View solution in original post

1 REPLY 1

Re: Enable Kerberos for Cluster

Contributor

The problem was PATH for the ktutil. 

solved.

View solution in original post