Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Enabling auto-TLS, failed to receive heartbeat from agent.

Enabling auto-TLS, failed to receive heartbeat from agent.

Install CDH step by step followed the document.

 

Enabled auto-TLS, after all agents are installed, get error message:

 

 Installation failed. Failed to receive heartbeat from agent.
Ensure that the host's hostname is configured properly.
Ensure that port 7182 is accessible on the Cloudera Manager Server (check firewall rules).
Ensure that ports 9000 and 9001 are not in use on the host being added.
Check agent logs in /var/log/cloudera-scm-agent/ on the host being added. (Some of the logs can be found in the installation details).
If Use TLS Encryption for Agents is enabled in Cloudera Manager (Administration -> Settings -> Security), ensure that /etc/cloudera-scm-agent/config.ini has use_tls=1 on the host being added. Restart the corresponding agent and click the Retry link here.

 

And in the log:

 

 Installation failed. Failed to receive heartbeat from agent.
Ensure that the host's hostname is configured properly.
Ensure that port 7182 is accessible on the Cloudera Manager Server (check firewall rules).
Ensure that ports 9000 and 9001 are not in use on the host being added.
Check agent logs in /var/log/cloudera-scm-agent/ on the host being added. (Some of the logs can be found in the installation details).
If Use TLS Encryption for Agents is enabled in Cloudera Manager (Administration -> Settings -> Security), ensure that /etc/cloudera-scm-agent/config.ini has use_tls=1 on the host being added. Restart the corresponding agent and click the Retry link here.

I noticed "An Enterprise license is required to enable Auto-TLS. ",  is that a problem? I don't hive a Enterprise license for CDH.

4 REPLIES 4

Re: Enabling auto-TLS, failed to receive heartbeat from agent.

Rising Star
No, That's not required for TLS. It needs for LDAP and SAML etc.
https://www.cloudera.com/documentation/enterprise/5-15-x/topics/cm_ag_licenses.html#cmug_topic_13_7_...
But other things worth to check like ports and config.ini file (use_tls=1)

Re: Enabling auto-TLS, failed to receive heartbeat from agent.

Rising Star

@kernel8liang Apologies for Miscommunication. Please follow the solution provided by @bgooley'. 

Re: Enabling auto-TLS, failed to receive heartbeat from agent.

Super Guru

@kernel8liang,

 

Actually, yes you do need an enterprise license to use Auto-TLS as mentioned here:

 

https://www.cloudera.com/documentation/enterprise/latest/topics/auto_tls.html#auto_tls

 

This applies to Cloudera Manager 6.0.1 and up.

 

 

Re: Enabling auto-TLS, failed to receive heartbeat from agent.

Super Guru

NOTE:

 

You can grep your /var/log/cloudera-scm-server/cloudera-scm-server.log file for the following which will be printed if Auto-TLS failed due to license restriction:

 

Did not generate Auto-TLS certificates because of missing enterprise license

 

This will appear at the time you attempted the install.

Don't have an account?
Coming from Hortonworks? Activate your account here