Support Questions

Find answers, ask questions, and share your expertise

Error During HDP Installation - Repos on Redhat Satellite Server


We are trying to install HDP2.6.5 using Ambari As the machines are within a firewall region, we have configured a Redhat Satellite server which hosts all the required repos and packages for HDP installation.

However, when we install it using Ambari Installation Wizard, we are facing issues. In the step 1 of installation, I have provided a custom stack definition file which has the <version> element as and <build> element as 1

Also, we have chosen the "Use Local Repository" option with the OS being redhat7. For the Base URLs corresponding to various remiss, I have provided as http://public as the URL and have checked the "Skip Repository Base URL validation" checkbox along with the "Use Redhat Satellite Spacewalk" checkbox as well. In my opinion, the Base URLs are not significant in the case of satellite server deployment and hence provided some dummy value. Inline to my thinking, upon selecting the Redhat Satellite Spacewalk checkbox, BaseURL elements are disabled and becomes uneditable.

From here on, we are able to proceed all the way to Step9 - Install, Start and Test. However, here component installation get failed. Right now, we are facing the issue with ZooKeeper installation as the only component we chose to install, just to check installation works fine.

The error we are seeing the below error message in Ambari wizard:

The'zookeeper-server' component did not advertise a version.This may indicate a problem with the component packaging.However, the stack-select tool was able to report a single version installed ( the version that will be reported.

Has anyone experienced similar issue below and were able to resolve? Any further pointers to allow us move forward?

Thanks in Advance.


@Greenhorn Techie

In VDF file provide the satelite repo tag in "<repoid>TAGNAME</repoid>" and re-create the version and then attempt the installation process.

@amarnath reddy pappuWe have already populated the repoid with the repaid information from satellite server. On our satellite, the channel name, repo id and repo name are one and the same.

We are experiencing this issue despite all these changes. Any further inputs / alternatives to try?


@Greenhorn Techie

Can you please check if the component is already installed? you can check with

yum list installed | grep -i zookeeper-server

If it is already installed using some other tag or so - please remove/uninstall so that Ambari can install using the correct repoId tag.

@amarnath reddy pappu

Thanks for your response. I tried deleting the packages on the host machine and tried reinstalling the cluster from start. But still no luck and the same error recurring.

@Greenhorn Techie

Is it failing at the same component? if it is another component then remove all the existing installed components that installed manually ( or outside of Ambari)