Support Questions
Find answers, ask questions, and share your expertise

Error: Package: 1:openssl-devel-1.0.1e-60.el7.x86_64

New Contributor

I am trying to install Cloudera Manager and getting following error. 

 

Any idea on what I can do to fix this issue ?

---> Package libsepol-devel.x86_64 0:2.5-6.el7 will be installed

 

---> Package openssl-devel.x86_64 1:1.0.1e-60.el7 will be installed
--> Processing Dependency: openssl-libs(x86-64) = 1:1.0.1e-60.el7 for package: 1:openssl-devel-1.0.1e-60.el7.x86_64
---> Package pcre-devel.x86_64 0:8.32-15.el7_2.1 will be installed
--> Finished Dependency Resolution
Error: Package: 1:openssl-devel-1.0.1e-60.el7.x86_64 (***-uscloudrepo.informatica.com)
Requires: openssl-libs(x86-64) = 1:1.0.1e-60.el7
Installed: 1:openssl-libs-1.0.2k-19.el7.x86_64 (@***-uscloudrepo.informatica.com)
openssl-libs(x86-64) = 1:1.0.2k-19.el7

3 REPLIES 3

@nj20200 This is yum related issue where yum found a newer version (openssl-libs(x86-64) = 1:1.0.1e-60.el7) of openssl and that's being conflicted.

 

You can do something like below on the host to resolve the issue.

yum install openssl-devel-1.0.1e-60 openssl-libs-1.0.1e-60 openssl-1.0.1e-60

 Then restart the installation. 


Cheers!
Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.

Cloudera Employee

@nj20200 

 

As @GangWar  mentioned, this is more of a yum related issue. Cloudera manager requires openssl, openssl-libs, and openssl-devel packages to be installed. It appears your yum repo server does not contain openssl-devel-1.0.2k-19.el7.x86_64.rpm, and hence the error. Once your OS team or the team that manages the repo server is able to sync or copy the required openssl rpms from satellite server, you should be able to install cloudera manager package without any issue. 

Rising Star

Hello @nj20200 It seems there is an older/previous version of openssl-devel package (openssl-libs-1.0.2k-19.el7.x86_64) is installed, which is causing the installation failure of new version openssl-devel package (openssl-devel-1.0.1e-60.el7.x86_64). 

 

So instead of installing the package, update the openssl-devel package by running 

"#yum update openssl-devel with -force option"  or just remove the previous package and install the new version of openssl-devel package. 

; ;