Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Error in Horton Schema registry with Nifi

Highlighted

Error in Horton Schema registry with Nifi

I Have setup a hortonworks schema registry by following the below post

https://community.hortonworks.com/articles/119766/installing-a-local-hortonworks-registry-to-use-wit...

I able to register Schema in UI and also reteriev schema via curl command( referred Swagger UI).

But I try and test a processor I get an error saying schema not founded.

I kept the url as localhost as mentioned in post and was able to use Curl command.But the Nifi processor fails

As per logs(attached)schema-error-logs.txt it looks like the schema is being retrieved ,i see some kind of avro the structure.

Is there any config that I have missed

2 REPLIES 2
Highlighted

Re: Error in Horton Schema registry with Nifi

It is an issue with the versions of NiFi and schema registry being used, I would suggest using the latest version of both..

If you are using HDF then you can install both of them via ambari, the latest release is 3.1.1.

If you are installing manually, then...

https://github.com/hortonworks/registry/releases

https://nifi.apache.org/download.html

Highlighted

Re: Error in Horton Schema registry with Nifi

Thanks @Bryan Bende

Don't have an account?
Coming from Hortonworks? Activate your account here