Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Error in Metron full-dev-platfrom installation

Solved Go to solution
Highlighted

Error in Metron full-dev-platfrom installation

New Contributor

Hi. I have been trying to install Metron full-dev-platform and am getting the following error when I say vagrant provision. Could you please explain why this could be happening?,Hi. I am trying to perform a full-dev-install of Metron but am getting the following error when I do vagrant provision. Could you please explain what is causing this?

fatal: [node1]: FAILED! => {"failed": true, "msg": "failed to transfer file to /home/vagrant/.ansible/tmp/ansible-tmp-1473164702.56-36772171769600/setup:\n\nsftp: illegal option -- i\nusage: sftp [-1Cv] [-B buffer_size] [-b batchfile] [-F ssh_config]\n [-o ssh_option] [-P sftp_server_path] [-R num_requests]\n [-S program] [-s subsystem | sftp_server] host\n sftp [user@]host[:file ...]\n sftp [user@]host[:dir[/]]\n sftp -b batchfile [user@]host\n"}

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Error in Metron full-dev-platfrom installation

New Contributor

Edit your Vagrantfile and add this to the bottom, under "[ssh_connection]":

scp_if_ssh = True

I have a ticket open to fix this issue for the next release.

4 REPLIES 4

Re: Error in Metron full-dev-platfrom installation

Super Collaborator

Hello @Rashmi Varma, can you post the output of 'incubator-metron/metron-deployment/scripts/platform-info.sh' from your setup?

Re: Error in Metron full-dev-platfrom installation

Guru

I have heard that full-dev-platform is being deprecated and vagrant-multinode should be used for a development envt instead: https://github.com/apache/incubator-metron/tree/master/metron-deployment/vagrant/multinode-vagrant

This is very resource intensive, so for dev the best option is: https://github.com/apache/incubator-metron/tree/master/metron-deployment/vagrant/quick-dev-platform

Also, ansible should be installed latest version and downgraded as follows: https://cwiki.apache.org/confluence/display/METRON/Downgrade+Ansible

Re: Error in Metron full-dev-platfrom installation

New Contributor

Edit your Vagrantfile and add this to the bottom, under "[ssh_connection]":

scp_if_ssh = True

I have a ticket open to fix this issue for the next release.

Re: Error in Metron full-dev-platfrom installation

New Contributor

Thanks for the help.