Support Questions
Find answers, ask questions, and share your expertise

Error in metron dashboard deployment

Solved Go to solution
Highlighted

Error in metron dashboard deployment

Hi. I am doing full-dev-platfrom of Metron and have reached the stage where kibana dashboard is getting deployed but am getting the following error:

: [node1]: FAILED! => {"changed": true, "cmd": "elasticdump --output=http://node1:9200/.kibana --input=/tmp/kibana-index.json", "delta": "0:00:00.494524", "end": "2016-09-13 05:13:18.150559", "failed": true, "rc": 1, "start": "2016-09-13 05:13:17.656035", "stderr": "Tue, 13 Sep 2016 05:13:18 GMT | Error Emitted => Cannot read property 'body' of undefined", "stdout": "Tue, 13 Sep 2016 05:13:18 GMT | starting dump\nTue, 13 Sep 2016 05:13:18 GMT | got 34 objects from source file (offset: 0)\nTue, 13 Sep 2016 05:13:18 GMT | Total Writes: 0\nTue, 13 Sep 2016 05:13:18 GMT | dump ended with error (set phase) => TypeError: Cannot read property 'body' of undefined", "stdout_lines": ["Tue, 13 Sep 2016 05:13:18 GMT | starting dump", "Tue, 13 Sep 2016 05:13:18 GMT | got 34 objects from source file (offset: 0)", "Tue, 13 Sep 2016 05:13:18 GMT | Total Writes: 0", "Tue, 13 Sep 2016 05:13:18 GMT | dump ended with error (set phase) => TypeError: Cannot read property 'body' of undefined"], "warnings": []}

Please inform how to fix this.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Error in metron dashboard deployment

Rising Star

That error is often caused by running a version of Ansible that is not 2.0.0.2. Could you run incubator-metron/metron-deployment/scripts/platform-info.sh and verify that the versions output match Required Versions?

View solution in original post

3 REPLIES 3
Highlighted

Re: Error in metron dashboard deployment

Rising Star

That error is often caused by running a version of Ansible that is not 2.0.0.2. Could you run incubator-metron/metron-deployment/scripts/platform-info.sh and verify that the versions output match Required Versions?

View solution in original post

Highlighted

Re: Error in metron dashboard deployment

Thanks for the help. I downgraded Ansible to 2.0 and the installation script went ahead smoothly.

,

Thanks for the help. I downgraded Ansible to 2.0. and it went ahead smoothly. I have been able to deploy Metron now. Thank you very much.

Re: Error in metron dashboard deployment

Rising Star

Glad to hear it worked. If you haven't, would you mind accepting the above answer?

Thanks!

-David...