Support Questions

Find answers, ask questions, and share your expertise
Announcements
Celebrating as our community reaches 100,000 members! Thank you!

Error installing CM Agent

avatar
Explorer

Hello- I was unable to install CM Agent, used different options but was having the same issue. Could you help if you have seen this issue. Thanks!

 

[root@lsdne9sgeot cloudera]# yum --nogpgcheck localinstall cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64.rpm

Loaded plugins: langpacks

Examining cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64.rpm: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

Marking cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64.rpm to be installed

Resolving Dependencies

--> Running transaction check

---> Package cloudera-manager-agent.x86_64 0:5.7.0-1.cm570.p0.76.el6 will be installed

--> Processing Dependency: cyrus-sasl-gssapi for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

--> Processing Dependency: fuse for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

--> Processing Dependency: fuse-libs for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

--> Processing Dependency: /lib/lsb/init-functions for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

--> Processing Dependency: httpd for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

--> Processing Dependency: mod_ssl for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

--> Processing Dependency: openssl-devel for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

--> Processing Dependency: python-psycopg2 for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

--> Processing Dependency: MySQL-python for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

--> Running transaction check

---> Package MySQL-python.x86_64 0:1.2.3-11.el7 will be installed

---> Package cloudera-manager-agent.x86_64 0:5.7.0-1.cm570.p0.76.el6 will be installed

--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

---> Package cyrus-sasl-gssapi.x86_64 0:2.1.26-20.el7_2 will be installed

---> Package fuse.x86_64 0:2.9.2-6.el7 will be installed

---> Package fuse-libs.x86_64 0:2.9.2-6.el7 will be installed

---> Package httpd.x86_64 0:2.4.6-40.el7 will be installed

--> Processing Dependency: httpd-tools = 2.4.6-40.el7 for package: httpd-2.4.6-40.el7.x86_64

--> Processing Dependency: /etc/mime.types for package: httpd-2.4.6-40.el7.x86_64

---> Package mod_ssl.x86_64 1:2.4.6-40.el7 will be installed

---> Package openssl-devel.x86_64 1:1.0.1e-51.el7_2.5 will be installed

--> Processing Dependency: zlib-devel(x86-64) for package: 1:openssl-devel-1.0.1e-51.el7_2.5.x86_64

--> Processing Dependency: krb5-devel(x86-64) for package: 1:openssl-devel-1.0.1e-51.el7_2.5.x86_64

---> Package python-psycopg2.x86_64 0:2.5.1-3.el7 will be installed

--> Processing Dependency: libpq.so.5()(64bit) for package: python-psycopg2-2.5.1-3.el7.x86_64

---> Package redhat-lsb-core.x86_64 0:4.1-27.el7 will be installed

--> Processing Dependency: redhat-lsb-submod-security(x86-64) = 4.1-27.el7 for package: redhat-lsb-core-4.1-27.el7.x86_64

--> Processing Dependency: spax for package: redhat-lsb-core-4.1-27.el7.x86_64

--> Processing Dependency: /usr/bin/patch for package: redhat-lsb-core-4.1-27.el7.x86_64

--> Processing Dependency: /usr/bin/m4 for package: redhat-lsb-core-4.1-27.el7.x86_64

--> Processing Dependency: /usr/bin/lpr for package: redhat-lsb-core-4.1-27.el7.x86_64

--> Processing Dependency: /usr/bin/lp for package: redhat-lsb-core-4.1-27.el7.x86_64

--> Running transaction check

---> Package cloudera-manager-agent.x86_64 0:5.7.0-1.cm570.p0.76.el6 will be installed

--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

---> Package cups-client.x86_64 1:1.6.3-22.el7 will be installed

--> Processing Dependency: cups-libs(x86-64) = 1:1.6.3-22.el7 for package: 1:cups-client-1.6.3-22.el7.x86_64

--> Processing Dependency: libcups.so.2()(64bit) for package: 1:cups-client-1.6.3-22.el7.x86_64

---> Package httpd-tools.x86_64 0:2.4.6-40.el7 will be installed

---> Package krb5-devel.x86_64 0:1.13.2-12.el7_2 will be installed

--> Processing Dependency: libverto-devel for package: krb5-devel-1.13.2-12.el7_2.x86_64

--> Processing Dependency: libselinux-devel for package: krb5-devel-1.13.2-12.el7_2.x86_64

--> Processing Dependency: libcom_err-devel for package: krb5-devel-1.13.2-12.el7_2.x86_64

--> Processing Dependency: keyutils-libs-devel for package: krb5-devel-1.13.2-12.el7_2.x86_64

---> Package m4.x86_64 0:1.4.16-10.el7 will be installed

---> Package mailcap.noarch 0:2.1.41-2.el7 will be installed

---> Package patch.x86_64 0:2.7.1-8.el7 will be installed

---> Package postgresql-libs.x86_64 0:9.2.15-1.el7_2 will be installed

---> Package redhat-lsb-submod-security.x86_64 0:4.1-27.el7 will be installed

---> Package spax.x86_64 0:1.5.2-13.el7 will be installed

---> Package zlib-devel.x86_64 0:1.2.7-15.el7 will be installed

--> Running transaction check

---> Package cloudera-manager-agent.x86_64 0:5.7.0-1.cm570.p0.76.el6 will be installed

--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

---> Package cups-libs.x86_64 1:1.6.3-22.el7 will be installed

---> Package keyutils-libs-devel.x86_64 0:1.5.8-3.el7 will be installed

---> Package libcom_err-devel.x86_64 0:1.42.9-7.el7 will be installed

---> Package libselinux-devel.x86_64 0:2.2.2-6.el7 will be installed

--> Processing Dependency: libsepol-devel >= 2.1.9-1 for package: libselinux-devel-2.2.2-6.el7.x86_64

--> Processing Dependency: pkgconfig(libsepol) for package: libselinux-devel-2.2.2-6.el7.x86_64

--> Processing Dependency: pkgconfig(libpcre) for package: libselinux-devel-2.2.2-6.el7.x86_64

---> Package libverto-devel.x86_64 0:0.2.5-4.el7 will be installed

--> Running transaction check

---> Package cloudera-manager-agent.x86_64 0:5.7.0-1.cm570.p0.76.el6 will be installed

--> Processing Dependency: libpython2.6.so.1.0()(64bit) for package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64

---> Package libsepol-devel.x86_64 0:2.1.9-3.el7 will be installed

---> Package pcre-devel.x86_64 0:8.32-15.el7 will be installed

--> Finished Dependency Resolution

Error: Package: cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64 (/cloudera-manager-agent-5.7.0-1.cm570.p0.76.el6.x86_64)

           Requires: libpython2.6.so.1.0()(64bit)

You could try using --skip-broken to work around the problem

You could try running: rpm -Va --nofiles --nodigest

 

1 ACCEPTED SOLUTION

avatar
Master Collaborator
hide-solution

This problem has been solved!

Want to get a detailed solution you have to login/registered on the community

Register/Login
11 REPLIES 11

avatar
Explorer

Hello Michalis,

 

Do we need a Cloudera Agent on the Cloudera manager server too? We have allocated one server for Cloudera manager and 3 for the Kafka broker. Already installed agents on the broker box.. wanted to confirm if we need a agent on the CM server too. Thanks!

avatar
New Contributor

Thank you Bannu! Simply editing my cloudera-manager.rep file to have the baseurl and gpgkey you mentioned in your post did the trick for me. Also, my server is connected to the internet, so I can't comment on creating a private repo.