Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Error installing HAWQ in Ambari 2.2.2

Solved Go to solution
Highlighted

Error installing HAWQ in Ambari 2.2.2

New Contributor

Tried installing HAWQ in HDP 2.4 Sandbox environment. Upgraded the Ambari to 2.2.2 and then followed the instruction from the below link :

http://hdb.docs.pivotal.io/20/install/install-ambari.html

Since the port 5432 which is the default port of HAWQ was already used in Sandbox , I check the available port and assigned port number 5433 for HAWQ Master Port.

When I am trying for install I got the below error where the HAWQ Master Start is getting error and not able to initiate the service.

4277-screen-shot-2016-05-16-at-41301-pm.png

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Error installing HAWQ in Ambari 2.2.2

New Contributor

Further investigation of the error into the Hawq logs noticed that the HAWQ Master was trying to copy some folders and files in the folder /data/hawq/master , but since the folder was already populated with some files and folder , the process was expecting this folder to be empty, due to which the Master init failed.

So I backed up the content from the folder /data/hawq/master and emptied the folder. When I tried to install now through Ambari 2.2.2 , it went through and was able to successfully install the HAWQ Services in Ambari and both HAWQ and PXF Services were up and running.

1 REPLY 1

Re: Error installing HAWQ in Ambari 2.2.2

New Contributor

Further investigation of the error into the Hawq logs noticed that the HAWQ Master was trying to copy some folders and files in the folder /data/hawq/master , but since the folder was already populated with some files and folder , the process was expecting this folder to be empty, due to which the Master init failed.

So I backed up the content from the folder /data/hawq/master and emptied the folder. When I tried to install now through Ambari 2.2.2 , it went through and was able to successfully install the HAWQ Services in Ambari and both HAWQ and PXF Services were up and running.

Don't have an account?
Coming from Hortonworks? Activate your account here