Support Questions

Find answers, ask questions, and share your expertise

Error on putsolrcontentstream processor on nifi when configuring it with Solr


I have spinned up solr through Ambari and Nifi is installed on hortonworks sandbox. When I added processor "putsolrcontentstream" it gave me an error "IOException occured when talking to server at:". My guess is that Nifi is trying to connect to whereas tweets_shard1_replical is in below address and i can see it in my browser I checked on solr UI --> Java properties that HOST is given as and ZKHOST is given as QUESTION: How to replace and where to replace with so that I no longer get error on putsolrcontentstream processor on nifi. Attached are relevant screenshots for reference purpose. Please help.

Thanks! in Advance





Have you tried adding a /etc/hosts entry for: sandbox

Yes, I tried that also. Alongside localhost I gave (i.e localhost too and then restarted the service, surprisingly it had reset again to localhost.

Not sure how can I do it.

In the PutSolrContentStream processor, did include the Collection name in the properties? What are the other properties that you have set in processor.

Please find attached then screenshot of PutSolrContentStream properties. Please let me know if I'm missing anything.


when you started solr, did you specify localhost:2181/solr as the zk location? i.e. / start -c -z localhost:2181/solr. If not, make sure the zk location you started in the solr setup is the same in the PutSolr properties. I've also had times where I had to recreate the index to get this error message to go away.

Thanks for responding guys. I anyway got the issue resolved by doing entry like in C:/Windows/Sytem32/driver/etc/hosts file on my windows machine.

I didn't realise you were using Windows - that was what my comment above was instructing you to do, sorry for not being clearer.