Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]
Created 06-21-2024 08:43 AM
Hi Team,
We are using Hadoop version 2.10.2 version and facing below error while starting server. Due to company security policy no execution permission is enabled on /tmp directory. Is there any better alternate way by which we can resolve this? I am new to Hadoop project and help is much appreciated. Many Thanks in advance.
Logs Message: 2024-06-13 09:57:00,871 ERROR org.apache.hadoop.yarn.server.nodemanager.NodeManager: Error starting NodeManager
java.lang.UnsatisfiedLinkError: Could not load library. Reasons: [no leveldbjni64-1.8 in java.library.path, no leveldbjni-1.8 in java.library.path, no leveldbjni in java.library.path, /tmp/libleveldbjni-64-1-7115603708108814032.8: /tmp/libleveldbjni-64-1-7115603708108814032.8: failed to map segment from shared object]
at org.fusesource.hawtjni.runtime.Library.doLoad(Library.java:182)
at org.fusesource.hawtjni.runtime.Library.load(Library.java:140)
at org.fusesource.leveldbjni.JniDBFactory.<clinit>(JniDBFactory.java:48)
at org.apache.hadoop.yarn.server.nodemanager.recovery.NMLeveldbStateStoreService.openDatabase(NMLeveldbStateStoreService.java:1699)
at org.apache.hadoop.yarn.server.nodemanager.recovery.NMLeveldbStateStoreService.initStorage(NMLeveldbStateStoreService.java:1687)
at org.apache.hadoop.yarn.server.nodemanager.recovery.NMStateStoreService.serviceInit(NMStateStoreService.java:355)
at org.apache.hadoop.service.AbstractService.init(AbstractService.java:164)
at org.apache.hadoop.yarn.server.nodemanager.NodeManager.initAndStartRecoveryStore(NodeManager.java:281)
at org.apache.hadoop.yarn.server.nodemanager.NodeManager.serviceInit(NodeManager.java:358)
at org.apache.hadoop.service.AbstractService.init(AbstractService.java:164)
at org.apache.hadoop.yarn.server.nodemanager.NodeManager.initAndStartNodeManager(NodeManager.java:878)
at org.apache.hadoop.yarn.server.nodemanager.NodeManager.main(NodeManager.java:946)
2024-06-13 09:57:00,905 INFO org.apache.hadoop.service.AbstractService: Service NodeManager failed in state STOPPED; cause: java.lang.NullPointerException
java.lang.NullPointerException
at org.apache.hadoop.yarn.server.nodemanager.NodeManager.serviceStop(NodeManager.java:482)
at org.apache.hadoop.service.AbstractService.stop(AbstractService.java:222)
at org.apache.hadoop.service.ServiceOperations.stop(ServiceOperations.java:54)
at org.apache.hadoop.service.ServiceOperations.stopQuietly(ServiceOperations.java:104)
at org.apache.hadoop.service.ServiceOperations.stopQuietly(ServiceOperations.java:67)
at org.apache.hadoop.service.CompositeService$CompositeServiceShutdownHook.run(CompositeService.java:184)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
java.lang.NullPointerException
at org.apache.hadoop.yarn.server.nodemanager.NodeManager.serviceStop(NodeManager.java:482)
at org.apache.hadoop.service.AbstractService.stop(AbstractService.java:222)
at org.apache.hadoop.service.ServiceOperations.stop(ServiceOperations.java:54)
at org.apache.hadoop.service.ServiceOperations.stopQuietly(ServiceOperations.java:104)
at org.apache.hadoop.service.ServiceOperations.stopQuietly(ServiceOperations.java:67)
at org.apache.hadoop.service.CompositeService$CompositeServiceShutdownHook.run(CompositeService.java:184)
at java.util.concurrent.Executors$RunnableAdapter.call(Executors.java:511)
at java.util.concurrent.FutureTask.run(FutureTask.java:266)
at java.util.concurrent.ThreadPoolExecutor.runWorker(ThreadPoolExecutor.java:1149)
at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:624)
at java.lang.Thread.run(Thread.java:748)
2024-06-13 10:33:36,622 INFO org.apache.hadoop.yarn.server.nodemanager.NodeManager: SHUTDOWN_MSG:
Created 06-24-2024 11:53 PM
This problem looks to be duplicate of solution proposed here, https://community.cloudera.com/t5/Support-Questions/Problem-starting-a-nodemanager/m-p/40657/highlig...
Other ways, you can configure Hadoop to use a different directory for its temporary files. This can be done by setting the hadoop.tmp.dir configuration property in the Hadoop configuration files (core-site.xml).
Created 06-24-2024 10:48 AM
@prak_ Welcome to the Cloudera Community!
To help you get the best possible solution, I have tagged our Hadoop expert @sandeepV2 who may be able to assist you further.
Please keep us updated on your post, and we hope you find a satisfactory solution to your query.
Regards,
Diana Torres,Created 06-24-2024 11:53 PM
This problem looks to be duplicate of solution proposed here, https://community.cloudera.com/t5/Support-Questions/Problem-starting-a-nodemanager/m-p/40657/highlig...
Other ways, you can configure Hadoop to use a different directory for its temporary files. This can be done by setting the hadoop.tmp.dir configuration property in the Hadoop configuration files (core-site.xml).
Created 06-26-2024 01:52 AM
Thank you for response and apologies for delay reply. I have created a custom tmp directory as below under core-site.xml. I ran stop-all.sh and start-all.sh under sbin directory but still custom tmp directory is empty and not utilized. Is I need to do anything else, please suggest. Thanks in advance.
<property>
<name>hadoop.tmp.dir</name>
<value>/opt/osa/hadoop-2.10.2/tmp_Hadoop</value>
<description>A base for other temporary directories.</description>
</property>