Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Error when I create hive_process with Rest Api 2, the detail error code is "ObjectId is not valid"

Error when I create hive_process with Rest Api 2, the detail error code is "ObjectId is not valid"

New Contributor

Any help is appreciated

Here is my detail Post Info about outputs and inputs:

outputs: [ [AtlasObjectId { guid = '2f0ef48b-6689-4e52-be40-e5a25bd0ad38', typeName = 'hive_table', uniqueAttributes = { qualifiedName: Hive.default.test11 @187 .3 .70 .202 - cluster_1 } }] ],

inputs: [ [AtlasObjectId { guid = 'e4afb3b5-35a2-40f0-a431-8089e92f29ef', typeName = 'hive_table', uniqueAttributes = { qualifiedName: Hive.default.test12 @187 .3 .70 .202 - cluster_1 } }] ]

5 REPLIES 5

Re: Error when I create hive_process with Rest Api 2, the detail error code is "ObjectId is not valid"

New Contributor

I Guess the problem may be caused by the values of Inputs and Outputs

Re: Error when I create hive_process with Rest Api 2, the detail error code is "ObjectId is not valid"

Contributor

@haosheng lou is the issue resolved ? Can u post the code you are using and the log messages ? Can you also describe the entities that you trying to stitch with this process so can check the object id's & types.

Re: Error when I create hive_process with Rest Api 2, the detail error code is "ObjectId is not valid"

New Contributor
Here is the hive_process entity
AtlasEntity {
	AtlasStruct {
		typeName = 'hive_process', 
        attributes = [
            outputs: [
                [AtlasObjectId {
                    guid = '2f0ef48b-6689-4e52-be40-e5a25bd0ad38', 
                    typeName = 'hive_table', 
                    uniqueAttributes = {
                        qualifiedName: Hive.default.test11@187.3.70.202-cluster_1
                    }
                 }]], 
             inputs: [
                [AtlasObjectId {
                    guid = 'e4afb3b5-35a2-40f0-a431-8089e92f29ef', 
                    typeName = 'hive_table', 
                    uniqueAttributes = {
                        qualifiedName: Hive.default.test12@187.3.70.202-cluster_1
                    }
			}]], 
            recentQueries: [create table test11 as select * from test12], 
            qualifiedName: Hive.default.test12@187.3.70.202-cluster_1:1544498692885,    
        userName: admin, 
        queryId: create table test11 as select * from test12, 
        clusterName: 187.3 .70 .202 - cluster_1, 
        name: create table test11 as select * from test12, 
        queryText: create table test11 as select * from test12, 
        startTime: 1544498692929, 
        operationType: CREATETABLE, 
        queryPlan: {}, 
        endTime: 1544498692929
        ]
	}
	guid = '-3485258231478370', 
    status = null, 
    createdBy = 'null', 
    updatedBy = 'null', 
    displayText = 'null', 
    createTime = null, 
    updateTime = null, 
    version = 0, 
    relationshipAttributes = [], 
    classifications = [], 
    meanings = []
}

Re: Error when I create hive_process with Rest Api 2, the detail error code is "ObjectId is not valid"

New Contributor
Here are two hive_table entities that I try to create process 
hive_table test11
{
    "referredEntities": {},
    "entity": {
        "typeName": "hive_table",
        "attributes": {
            "owner": null,
            "temporary": false,
            "lastAccessTime": 0,
            "aliases": null,
            "qualifiedName": "Hive.default.test11@187.3.70.202-cluster_1",
            "columns": null,
            "description": null,
            "connectionType": "HIVE",
            "viewExpandedText": null,
            "sd": null,
            "tableType": null,
            "createTime": 0,
            "name": "test11",
            "connection": {
                "guid": "d46c1569-3ccf-4bd5-b5f6-f53bf5568f1e",
                "typeName": "Connection"
            },
            "comment": null,
            "partitionKeys": null,
            "parameters": null,
            "db": {
                "guid": "69597fd1-b45a-4f0b-99e9-b2e98c46c847",
                "typeName": "hive_db"
            },
            "retention": 0,
            "viewOriginalText": null
        },
        "guid": "2f0ef48b-6689-4e52-be40-e5a25bd0ad38",
        "status": "ACTIVE",
        "createTime": 1544240604347,
        "updateTime": 1544240604347,
        "version": 0,
        "displayText": "test11",
        "relationshipAttributes": {
            "inputToProcesses": [],
            "sd": null,
            "columns": [],
            "connection": {
                "guid": "d46c1569-3ccf-4bd5-b5f6-f53bf5568f1e",
                "typeName": "Connection",
                "displayText": "fihive_1023",
                "relationshipGuid": "0de93a8c-af2f-4483-abd8-be9d69a76944",
                "relationshipStatus": "ACTIVE",
                "relationshipAttributes": {
                    "typeName": "connection_resource"
                }
            },
            "partitionKeys": [],
            "meanings": [],
            "db": {
                "guid": "69597fd1-b45a-4f0b-99e9-b2e98c46c847",
                "typeName": "hive_db",
                "displayText": "default",
                "relationshipGuid": "0f63c255-80e0-4553-a3ca-1e6647891bd9",
                "relationshipStatus": "ACTIVE",
                "relationshipAttributes": {
                    "typeName": "hive_table_db"
                }
            },
            "outputFromProcesses": []
        }
    }
}
hive_table test10
{
    "referredEntities": {},
    "entity": {
        "typeName": "hive_table",
        "attributes": {
            "owner": null,
            "temporary": false,
            "lastAccessTime": 0,
            "aliases": null,
            "qualifiedName": "Hive.default.test10@187.3.70.202-cluster_1",
            "columns": null,
            "description": null,
            "connectionType": "HIVE",
            "viewExpandedText": null,
            "sd": null,
            "tableType": null,
            "createTime": 0,
            "name": "test10",
            "connection": {
                "guid": "d46c1569-3ccf-4bd5-b5f6-f53bf5568f1e",
                "typeName": "Connection"
            },
            "comment": null,
            "partitionKeys": null,
            "parameters": null,
            "db": {
                "guid": "69597fd1-b45a-4f0b-99e9-b2e98c46c847",
                "typeName": "hive_db"
            },
            "retention": 0,
            "viewOriginalText": null
        },
        "guid": "c43bda58-7b02-486b-baa7-324e6fd859d4",
        "status": "ACTIVE",
        "createTime": 1544241491453,
        "updateTime": 1544241177016,
        "version": 0,
        "displayText": "test10",
        "relationshipAttributes": {
            "inputToProcesses": [],
            "sd": null,
            "columns": [],
            "connection": {
                "guid": "d46c1569-3ccf-4bd5-b5f6-f53bf5568f1e",
                "typeName": "Connection",
                "displayText": "fihive_1023",
                "relationshipGuid": "f4788853-a7eb-4f1e-abfc-de8d5b845490",
                "relationshipStatus": "ACTIVE",
                "relationshipAttributes": {
                    "typeName": "connection_resource"
                }
            },
            "partitionKeys": [],
            "meanings": [],
            "db": {
                "guid": "69597fd1-b45a-4f0b-99e9-b2e98c46c847",
                "typeName": "hive_db",
                "displayText": "default",
                "relationshipGuid": "897601a7-1207-4e00-8dab-cd83d41909aa",
                "relationshipStatus": "ACTIVE",
                "relationshipAttributes": {
                    "typeName": "hive_table_db"
                }
            },
            "outputFromProcesses": []
        }
    }
}

Re: Error when I create hive_process with Rest Api 2, the detail error code is "ObjectId is not valid"

New Contributor

The detail Error log is

Metadata service API org.apache.atlas.AtlasClientV2$API_V2@3fa6696e failed with status 400 (Bad Request) Response Body ({"errorCode":"ATLAS-400-00-021","errorMessage":"ObjectId is not valid [{guid=2f0ef48b-6689-4e52-be40-e5a25bd0ad38, typeName=hive_table, uniqueAttributes={qualifiedName=Hive.default.test11@187.3.70.202-cluster_1}}]"})
Don't have an account?
Coming from Hortonworks? Activate your account here