Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Error when creating a Kudu table through Impala JDBC driver : table owner must not be null or empty

avatar
Explorer

Hello, 

 

We've recently migrated CDH from 5.16.2 to 6.3.3 and we now have the following message when we create a table using Impala JDBC driver (we are using the latest version 2.6.15.1017).

errorMessage:ImpalaRuntimeException: Error creating Kudu table 'impala::pdo.discoveries'
CAUSED BY: IllegalArgumentException: table owner must not be null or empty

 

When the same "create table" statement is executed in impala-shell, it works perfectly well.

The search for this error message in google did not find much result.

 

Any idea about the root cause ?

 

1 ACCEPTED SOLUTION

avatar
New Contributor

Hello,

 

I got the same issue as yours. I am running Kudu and Impala in docker. I can create tables from impala-shell but not using JDBC driver.

 

Is there any solution for this?

View solution in original post

3 REPLIES 3

avatar
New Contributor

Hello,

 

I got the same issue as yours. I am running Kudu and Impala in docker. I can create tables from impala-shell but not using JDBC driver.

 

Is there any solution for this?

avatar
New Contributor

Hello,

 

I tried with AuthMech=2 with UID as mentioned in the Cloudera Impala JDBC Driver documentation but I got HIveServer2 connection issue.

 

When I tried with AuthMech=0, along with UID (In my case no authentication is needed), it resolved the table owner error.

 

My connection string looks like -

 

jdbc:impala://localhost:21050/default;UseSasl=0;AuthMech=0;UID=impala

 

Hope this will resolve your issue as well.

avatar
Expert Contributor

Hi @JeromeAlbin 

 

Looks like https://issues.apache.org/jira/browse/IMPALA-9486

 

The Error pop up  because you are connecting to Impala anonymously (no user, no password).
You can specify a user (even if it's not declared in Kudu), then it should work


Please read the page 12 of the following document: https://docs.cloudera.com/documentation/other/connectors/impala-jdbc/2-6-15/Cloudera-JDBC-Driver-for...
Using User Name
-----------------------
This authentication mechanism requires a user name but does not require a password.
The user name labels the session, facilitating database tracking.

 

Does that answer your question ? if yes, then feel free to mark this post "accept as solution"

 

Regards,

vipin