Support Questions

Find answers, ask questions, and share your expertise

Error when creating a Kudu table through Impala JDBC driver : table owner must not be null or empty

New Contributor



We've recently migrated CDH from 5.16.2 to 6.3.3 and we now have the following message when we create a table using Impala JDBC driver (we are using the latest version

errorMessage:ImpalaRuntimeException: Error creating Kudu table 'impala::pdo.discoveries'
CAUSED BY: IllegalArgumentException: table owner must not be null or empty


When the same "create table" statement is executed in impala-shell, it works perfectly well.

The search for this error message in google did not find much result.


Any idea about the root cause ?



New Contributor



I got the same issue as yours. I am running Kudu and Impala in docker. I can create tables from impala-shell but not using JDBC driver.


Is there any solution for this?

New Contributor



I tried with AuthMech=2 with UID as mentioned in the Cloudera Impala JDBC Driver documentation but I got HIveServer2 connection issue.


When I tried with AuthMech=0, along with UID (In my case no authentication is needed), it resolved the table owner error.


My connection string looks like -




Hope this will resolve your issue as well.


Hi @JeromeAlbin 


Looks like


The Error pop up  because you are connecting to Impala anonymously (no user, no password).
You can specify a user (even if it's not declared in Kudu), then it should work

Please read the page 12 of the following document:
Using User Name
This authentication mechanism requires a user name but does not require a password.
The user name labels the session, facilitating database tracking.


Does that answer your question ? if yes, then feel free to mark this post "accept as solution"