Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Error when registering a lily indexer

Solved Go to solution
Highlighted

Error when registering a lily indexer

Champion Alumni

Hi ,

 

I am trying to  register a lily indexer after  creating the solr collection.I am getting the below warning  once I run the command.Apparently the log says zoo keeper connection string not specified.I am using cdh 4.6 and search 1.2.

Can some one help?

 

 

 

 

hbase-indexer add-indexer -n trial1indexer -c indexer-config.xml -cp solr.zk=xxx:2181,yyy:2181,bbb:2181,kkk:2181,ccc:2181,ddt:2181/solr -cp solr.collection=trial1_collection

 

LOGS:


SLF4J: Class path contains multiple SLF4J bindings.
SLF4J: Found binding in [jar:file:/opt/cloudera/parcels/SOLR-1.2.0-1.cdh4.5.0.p0.4/lib/hbase-solr/lib/slf4j-log4j12-1.6.1.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: Found binding in [jar:file:/usr/lib/zookeeper/lib/slf4j-log4j12-1.6.1.jar!/org/slf4j/impl/StaticLoggerBinder.class]
SLF4J: See http://www.slf4j.org/codes.html#multiple_bindings for an explanation.
ZooKeeper connection string not specified, using default: localhost:2181

[WARN ][16:19:03,775][host:2181)] org.apache.zookeeper.ClientCnxn - Session 0x0 for server null, unexpected error, closing socket connection and attempting reconnect
java.net.ConnectException: Connection refused
at sun.nio.ch.SocketChannelImpl.checkConnect(Native Method)
at sun.nio.ch.SocketChannelImpl.finishConnect(SocketChannelImpl.java:739)
at org.apache.zookeeper.ClientCnxnSocketNIO.doTransport(ClientCnxnSocketNIO.java:350)
at org.apache.zookeeper.ClientCnxn$SendThread.run(ClientCnxn.java:1068)
Indexer added: trial1indexer

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Error when registering a lily indexer

Expert Contributor
2 REPLIES 2
Highlighted

Re: Error when registering a lily indexer

Expert Contributor
Highlighted

Re: Error when registering a lily indexer

Champion Alumni

Hi 

 

It did work and I am able to index the documents now.

How ever when I go to solr admin page and query for the data ,I get an error message as below.I can see an increase in the number of documents indexed each time I put add a row into hbase.

 

 

 

This is what I have done in general.

1.set up lily.

2.Insert record into hbase

3.navigate to solr admin UI and created a solr core  for my collection.

 

 

I tried restarting the solr service once I saw this error but still keeps getting it.

 

error": { "msg": "no servers hosting shard: ", "code": 503 }

Don't have an account?
Coming from Hortonworks? Activate your account here