Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Error while installing R-Studio on HDP2.5. " initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused "

New Contributor

After running the following commands and downloading rStudio for centOS

wget http://download.fedoraproject.org/pub...

sudo yum -y localinstall epel-release-6-8.noarch.rpm

sudo yum -y install R wget https://download2.rstudio.org/rstudio-server-rhel-1.0.136-x86_64.rpm

sudo yum install --nogpgcheck rstudio-server-rhel-1.0.136-x86_64.rpm rstudio-server verify-installation

Resulting in the error:

initctl: Unable to connect to Upstart: Failed to connect to socket /com/ubuntu/upstart: Connection refused

also ran curl localhost:8787 resulting in "curl: (7) couldn't connect to host"

I tried exec /usr/lib/rstudio-server/bin/rserve resulting in "Connection to sandbox.hortonworks.com closed."

I tried to change port numbers in rserver.conf did not work.

Please let me know if there is a solution to this issue. There are a lot of similar queries online with no solution.

1 ACCEPTED SOLUTION

New Contributor

@Markus

Try this it worked for me

Go to file /etc/rstudio/rserver.conf

Change the default port from 8787 to 8090 as this port is not opened in the docker sandbox.

Delete any IP if mentioned in that file.

Get back to your root and run the following:

wget https://download2.rstudio.org/rstudio-server-rhel-0.99.893-x86_64.rpm

sudo yum install --nogpgcheck rstudio-server-rhel-0.99.893-x86_64.rpm

ln -s /usr/lib64/libssl.so.10 /usr/lib64/libssl.so.6

ln -s /usr/lib64/libcrypto.so.10 /usr/lib64/libcrypto.so.6

yum install dpkg

dpkg-divert --local --rename --add /sbin/initctl

ln -s /bin/true /sbin/initctl

yum install R

rstudio-server verify-installation

If running sandbox on Azure. Make sure you add port 8090 to security settings on your azure portal

Go into azure > click on your resource group > click on "hadoop-nsg" > click on the Icon next to "Inbound Security rules" > click on Add > give it a name and add 8090 under port number > save

Fire up your browser to port 8090. login using user: maria_dev pass: maria_dev

View solution in original post

2 REPLIES 2

Explorer

I have the same issues

Unfortunately I didn't find a solution yet. Did you?

New Contributor

@Markus

Try this it worked for me

Go to file /etc/rstudio/rserver.conf

Change the default port from 8787 to 8090 as this port is not opened in the docker sandbox.

Delete any IP if mentioned in that file.

Get back to your root and run the following:

wget https://download2.rstudio.org/rstudio-server-rhel-0.99.893-x86_64.rpm

sudo yum install --nogpgcheck rstudio-server-rhel-0.99.893-x86_64.rpm

ln -s /usr/lib64/libssl.so.10 /usr/lib64/libssl.so.6

ln -s /usr/lib64/libcrypto.so.10 /usr/lib64/libcrypto.so.6

yum install dpkg

dpkg-divert --local --rename --add /sbin/initctl

ln -s /bin/true /sbin/initctl

yum install R

rstudio-server verify-installation

If running sandbox on Azure. Make sure you add port 8090 to security settings on your azure portal

Go into azure > click on your resource group > click on "hadoop-nsg" > click on the Icon next to "Inbound Security rules" > click on Add > give it a name and add 8090 under port number > save

Fire up your browser to port 8090. login using user: maria_dev pass: maria_dev