Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Error while starting Hive

Solved Go to solution

Error while starting Hive

Rising Star

Hi,

 

I am getting below message when I start the Hive. I just installed CDH 5.4.

 

from cloudera manager:

 

Canary test failed to create file in directory /tmp/.cloudera_health_monitoring_canary_files.

 

from server:

 

Caused by: org.apache.hadoop.ipc.RemoteException(org.apache.hadoop.hdfs.server.namenode.SafeModeException): Cannot create directory /tmp/hive/hdfs/5502ca90-629f-4c7e-afd5-dada9535d15c. Name node is in safe mode.

The reported blocks 404 needs additional 504 blocks to reach the threshold 0.9990 of total blocks 908.

The number of live datanodes 3 has reached the minimum number 0. Safe mode will be turned off automatically once the thresholds have been reached.

 

 

How do I fix it?

 

Thanks!

1 ACCEPTED SOLUTION

Accepted Solutions

Re: Error while starting Hive

probably a typo. "courrpt" should be "corrupt"
3 REPLIES 3

Re: Error while starting Hive

"Name node is in safe mode" means not enough datanodes have reported in
with the block reports. Visit the Namenode UI to find out which datanodes
have not reported in yet.

Alternatively one or more datanodes have lost blocks from their local
filesystem. You can run the "sudo -u hdfs hdfs fsck / -listcourrptblocks"
command to see which files are corrupt

Regards,
Gautam Gopalakrishnan

Re: Error while starting Hive

Rising Star

when I run:

 

sudo -u hdfs hdfs fsck / -listcourrptblocks

 

i get:

 

fsck: Illegal option '-listcourrptblocks'

 

Re: Error while starting Hive

probably a typo. "courrpt" should be "corrupt"