Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Exception in implementing NiFi site-to-site protocol.

Solved Go to solution

Exception in implementing NiFi site-to-site protocol.

2016-06-23 17:00:36,333 ERROR [Timer-Driven Process Thread-3] o.a.nifi.remote.StandardRemoteGroupPort RemoteGroupPort[name=Remote Connection,target=http://host:7090/nifi] failed to communicate with http://host:7090/nifi due to java.net.SocketTimeoutException. I can access the target nifi instance with no issues.

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Exception in implementing NiFi site-to-site protocol.

Got it resolved the issue is firewall on remote machine. I had to disable the firewall to make it work.( service iptables stop).

View solution in original post

4 REPLIES 4
Highlighted

Re: Exception in implementing NiFi site-to-site protocol.

Have you had a chance to enable the site to site port on the receiving system (well both systems really)?

http://docs.hortonworks.com/HDPDocuments/HDF1/HDF-1.2/bk_AdminGuide/content/system_properties.html

Take a look at the "Site to Site Properties" section.

Highlighted

Re: Exception in implementing NiFi site-to-site protocol.

Hi,

Can you check if you have these properties set properly on both nodes?

nifi.remote.input.socket.host={host}

nifi.remote.input.socket.port={port}

nifi.remote.input.secure={false/true}

Thanks

Highlighted

Re: Exception in implementing NiFi site-to-site protocol.

Got it resolved the issue is firewall on remote machine. I had to disable the firewall to make it work.( service iptables stop).

View solution in original post

Highlighted

Re: Exception in implementing NiFi site-to-site protocol.

New Contributor

Hi,

If Firewall is disabled and still you get same issue, then add ip and host name in /etc/hosts file for ubuntu system.

My issue was resolved after adding host details in /etc/hosts file

Don't have an account?
Coming from Hortonworks? Activate your account here