Support Questions
Find answers, ask questions, and share your expertise
Announcements
Alert: Welcome to the Unified Cloudera Community. Former HCC members be sure to read and learn how to activate your account here.

Exception occurred while submitting Oozie job

Solved Go to solution

Exception occurred while submitting Oozie job

New Contributor

I am seeing following exception while submitting Oozie job on sandbox environment. Please help.

JA002: Unauthorized connection for super-user: oozie from IP 127.0.0.1 Caused by: org.apache.hadoop.ipc.RemoteException(org.apache.hadoop.security.authorize.AuthorizationException): Unauthorized connection for super-user: oozie from IP 127.0.0.1 at org.apache.hadoop.ipc.Client.call(Client.java:1468) at org.apache.hadoop.ipc.Client.call(Client.java:1399) at org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke(ProtobufRpcEngine.java:232) at com.sun.proxy.$Proxy39.getDelegationToken(Unknown Source) at org.apache.hadoop.yarn.api.impl.pb.client.ApplicationClientProtocolPBClientImpl.getDelegationToken(ApplicationClientProtocolPBClientImpl.java:306) ... 30 more

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Exception occurred while submitting Oozie job

Expert Contributor

@alina n

It looks like that you need to add value “localhost” or "127.0.0.1" for parameter hadoop.proxyuser.oozie.hosts in /etc/hadoop/conf/core-site.xml. Once you add this through ambari-ui, please save and restart the Oozie service.

<property>
      <name>hadoop.proxyuser.oozie.hosts</name>
      <value>127.0.0.1,localhost,sandbox.hortonworks.com</value>
</property>

Hope this helps you.

View solution in original post

1 REPLY 1
Highlighted

Re: Exception occurred while submitting Oozie job

Expert Contributor

@alina n

It looks like that you need to add value “localhost” or "127.0.0.1" for parameter hadoop.proxyuser.oozie.hosts in /etc/hadoop/conf/core-site.xml. Once you add this through ambari-ui, please save and restart the Oozie service.

<property>
      <name>hadoop.proxyuser.oozie.hosts</name>
      <value>127.0.0.1,localhost,sandbox.hortonworks.com</value>
</property>

Hope this helps you.

View solution in original post

Don't have an account?
Coming from Hortonworks? Activate your account here