Support Questions
Find answers, ask questions, and share your expertise
Announcements
Check out our newest addition to the community, the Cloudera Innovation Accelerator group hub.

Exception occurred while submitting Oozie job

New Contributor

I am seeing following exception while submitting Oozie job on sandbox environment. Please help.

JA002: Unauthorized connection for super-user: oozie from IP 127.0.0.1 Caused by: org.apache.hadoop.ipc.RemoteException(org.apache.hadoop.security.authorize.AuthorizationException): Unauthorized connection for super-user: oozie from IP 127.0.0.1 at org.apache.hadoop.ipc.Client.call(Client.java:1468) at org.apache.hadoop.ipc.Client.call(Client.java:1399) at org.apache.hadoop.ipc.ProtobufRpcEngine$Invoker.invoke(ProtobufRpcEngine.java:232) at com.sun.proxy.$Proxy39.getDelegationToken(Unknown Source) at org.apache.hadoop.yarn.api.impl.pb.client.ApplicationClientProtocolPBClientImpl.getDelegationToken(ApplicationClientProtocolPBClientImpl.java:306) ... 30 more

1 ACCEPTED SOLUTION

Expert Contributor

@alina n

It looks like that you need to add value “localhost” or "127.0.0.1" for parameter hadoop.proxyuser.oozie.hosts in /etc/hadoop/conf/core-site.xml. Once you add this through ambari-ui, please save and restart the Oozie service.

<property>
      <name>hadoop.proxyuser.oozie.hosts</name>
      <value>127.0.0.1,localhost,sandbox.hortonworks.com</value>
</property>

Hope this helps you.

View solution in original post

1 REPLY 1

Expert Contributor

@alina n

It looks like that you need to add value “localhost” or "127.0.0.1" for parameter hadoop.proxyuser.oozie.hosts in /etc/hadoop/conf/core-site.xml. Once you add this through ambari-ui, please save and restart the Oozie service.

<property>
      <name>hadoop.proxyuser.oozie.hosts</name>
      <value>127.0.0.1,localhost,sandbox.hortonworks.com</value>
</property>

Hope this helps you.