Support Questions
Find answers, ask questions, and share your expertise

Facing error while upgrading from HDP 2.3 to 2.4 using AMBARI

Solved Go to solution
Highlighted

Facing error while upgrading from HDP 2.3 to 2.4 using AMBARI

New Contributor

We are trying to upgrade to HDP from 2.3 to 2.4 using AMBARI. While installing HDP 2.4 using local repositories getting below error

2016-05-04 13:24:30,176 - Installing package gcc ('/usr/bin/yum -d 0 -e 0 -y install '--disablerepo=HDP-*' --enablerepo=HDP-2.4.0.0-169,HDP-UTILS-2.4.0.0-169 gcc') 2016-05-04 13:24:31,313 - Package Manager failed to install packages. Error: Execution of '/usr/bin/yum -d 0 -e 0 -y install '--disablerepo=HDP-*' --enablerepo=HDP-2.4.0.0-169,HDP-UTILS-2.4.0.0-169 gcc' returned 1. Error: Cannot retrieve repository metadata (repomd.xml) for repository: HDP-2.4.0.0-169. Please verify its path and try again Traceback (most recent call last): File "/var/lib/ambari-agent/cache/custom_actions/scripts/install_packages.py", line 376, in install_packages

Any help is highly appreciated. Server version is RHEL 6

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

Re: Facing error while upgrading from HDP 2.3 to 2.4 using AMBARI

New Contributor

I figured it out - the problem is with proxy setting in /etc/yum.conf.

I have corrected and it all worked fine. Thanks for all your response.

View solution in original post

5 REPLIES 5
Highlighted

Re: Facing error while upgrading from HDP 2.3 to 2.4 using AMBARI

@PARTHIBAN DHAYALAN

It seems your local repository didn't setup correctly.

can you paste the output?

yum list ambari-server

run below command if you are using clush to know from all the nodes.

clush -g all yum list ambari-server

Highlighted

Re: Facing error while upgrading from HDP 2.3 to 2.4 using AMBARI

New Contributor

yum list ambari-server

Loaded plugins: product-id, rhnplugin, security, subscription-manager

This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register. This system is receiving updates from RHN Classic or RHN Satellite.

rhel-x86_64-server-6 | 1.8 kB 00:00

rhel-x86_64-server-6/primary | 22 MB 00:13

rhel-x86_64-server-6 16873/16873

Installed Packages

ambari-server.x86_64 2.2.1.1-70 @Updates-ambari-2.2.1.1

Highlighted

Re: Facing error while upgrading from HDP 2.3 to 2.4 using AMBARI

Explorer

Can you check the repositories in /etc/yum.repos.d for the repo identified as HDP-2.4.0.0-169? Does the baseurl look correct? Are they reachable from the host? If not, you'll need to edit the base urls in the UI and try it again.

Highlighted

Re: Facing error while upgrading from HDP 2.3 to 2.4 using AMBARI

New Contributor

The repo file does exist and the base urls are reachable from the host.

Highlighted

Re: Facing error while upgrading from HDP 2.3 to 2.4 using AMBARI

New Contributor

I figured it out - the problem is with proxy setting in /etc/yum.conf.

I have corrected and it all worked fine. Thanks for all your response.

View solution in original post