Support Questions

Find answers, ask questions, and share your expertise

Failed to delete rpm-docker/.npm/_locks



I managed to run Metron once. But an issue occur after I shut it down ( I stop the process first with CTRL + C), and the next day when I try to run it again, I ran into an error:

failed: [node1 -> localhost] (item=mvn clean -P build-rpms) => {"changed": true, "cmd": "mvn clean -P build-rpms", "delta": "0:00:03.277711", "end": "2018-10-25 16:33:41.207664", "item": "mvn clean -P build-rpms", "msg": "non-zero return code", "rc": 1, "start": "2018-10-25 16:33:37.929953", "stderr": "", "stderr_lines": [], "stdout": "[INFO] Scanning for projects...
"[INFO] BUILD FAILURE", "[INFO] ------------------------------------------------------------------------", "[INFO] Total time: 2.105 s", "[INFO] Finished at: 2018-10-25T16:33:41+08:00", "[INFO] ------------------------------------------------------------------------", "[ERROR] Failed to execute goal org.apache.maven.plugins:maven-clean-plugin:3.0.0:clean (default-clean) on project metron-rpm: Failed to clean project: Failed to delete /home/<user>/metron/metron-deployment/packaging/docker/rpm-docker/.npm/_locks -> 

Any ideas on how to approach this?


Super Collaborator

Hi @Nor Liana Kamaruzzaman ,

Can you tell me which process you stopped (using Ctrl+C)? Did you do this inside the full-dev node or on your local host?

I usually do the following in order to stop a running full dev setup and resume

cd metron/metron-deployment/centos6
vagrant halt
# -> This will shutdown the VM instance gracefully
# Then when you want to resume, run:
vagrant up

Once the VM has come up, ambari-server process should be up and running (in case it hasn't, you can SSH to the node and issue ambari-server restart command)

Login to the ambari server (http://node1:8080) and start all the services using Actions -> 'Start All'


Hi @asubramanian,

I stopped during Ambari server deployment task.

Ah....okay, vagrant halt.Will take note of that. can I fix my current issue? Do I have to remove the node and metron, then re-clone the git, run the vagrant again ( the components are already installed)?

update: I tried vagrant halt, but the process doesn't seem to stop.

My process hangs/ stayed at :

TASK [ambari_config : Deploy cluster with Ambari: http://node1:8080 ] **************************

During this, I managed to open the Ambri gui for Metron.

Is it meant to stop / stay here? Or was I suppose to wait further?

If yes, how can I halt the process, as vagrant halt did nothing?