Our Community is getting an upgrade! To get everything ready for the relaunch, we’ll be placing the site in read-only mode starting September 21st.
We really appreciate your understanding while we get things set up behind the scenes. Catch up on all the exciting details about the move here.
Need help or have questions? Drop us a line at [email protected]

Support Questions

Find answers, ask questions, and share your expertise
Announcements
Share your experience with Cloudera on G2 and get a $25 Amazon Gift card.
Hi, I'm CLEO! Something exciting is coming to the Community. Stay Tuned!

Failed to execute tez graph. org.apache.tez.dag.api.TezUncheckedException: Invalid configuration of tez jars, tez.lib.uris is not defined in the configuration

avatar
New Contributor

Hi, 

 

I have CDP private Cloud Base version 7.4.4 running in EC2 instance. I have hive, hive onTez and Tez services running. When I try to execute query in hive I get below issue

 

sss123_0-1663328970865.png 

 

Tez session hasn't been created yet. Opening session

ERROR : Failed to execute tez graph.

 

org.apache.tez.dag.api.TezUncheckedException: Invalid configuration of tez jars, tez.lib.uris is not defined in the configuration

 

 

 

Below is the complete error log 

INFO  : Compiling command(queryId=hive_20220915080651_6fe3fec1-a2ab-462b-ad3c-e7f4d53c2b46):

 

 

insert into customer values('sample1','1')

INFO  : Semantic Analysis Completed (retrial = false)

INFO  : Created Hive schema: Schema(fieldSchemas:[FieldSchema(name:col1, type:string, comment:null), FieldSchema(name:col2, type:string, comment:null)], properties:null)

INFO  : Completed compiling command(queryId=hive_20220915080651_6fe3fec1-a2ab-462b-ad3c-e7f4d53c2b46); Time taken: 0.121 seconds

INFO  : Executing command(queryId=hive_20220915080651_6fe3fec1-a2ab-462b-ad3c-e7f4d53c2b46):

 

 

insert into customer values('sample1','1')

INFO  : Query ID = hive_20220915080651_6fe3fec1-a2ab-462b-ad3c-e7f4d53c2b46

INFO  : Total jobs = 1

INFO  : Launching Job 1 out of 1

INFO  : Starting task [Stage-1:MAPRED] in serial mode

WARN  : The session: sessionId=9940e671-640e-46d3-b9ae-4ff27d255256, queueName=null, user=hive, doAs=false, isOpen=false, isDefault=false has not been opened

INFO  : Subscribed to counters: [] for queryId: hive_20220915080651_6fe3fec1-a2ab-462b-ad3c-e7f4d53c2b46

INFO  : Tez session hasn't been created yet. Opening session

ERROR : Failed to execute tez graph.

org.apache.tez.dag.api.TezUncheckedException: Invalid configuration of tez jars, tez.lib.uris is not defined in the configuration

          at org.apache.tez.client.TezClientUtils.setupTezJarsLocalResources(TezClientUtils.java:180) ~[tez-api-0.9.1.7.1.7.0-551.jar:0.9.1.7.1.7.0-551]

          at org.apache.tez.client.TezClient.getTezJarResources(TezClient.java:1095) ~[tez-api-0.9.1.7.1.7.0-551.jar:0.9.1.7.1.7.0-551]

          at org.apache.tez.client.TezClient.setupApplicationContext(TezClient.java:477) ~[tez-api-0.9.1.7.1.7.0-551.jar:0.9.1.7.1.7.0-551]

          at org.apache.tez.client.TezClient.start(TezClient.java:404) ~[tez-api-0.9.1.7.1.7.0-551.jar:0.9.1.7.1.7.0-551]

          at org.apache.hadoop.hive.ql.exec.tez.TezSessionState.startSessionAndContainers(TezSessionState.java:536) ~[hive-exec-3.1.3000.7.1.7.0-551.jar:3.1.3000.7.1.7.0-551]

          at org.apache.hadoop.hive.ql.exec.tez.TezSessionState.openInternal(TezSessionState.java:374) ~[hive-exec-3.1.3000.7.1.7.0-551.jar:3.1.3000.7.1.7.0-551]

          at org.apache.hadoop.hive.ql.exec.tez.TezSessionState.open(TezSessionState.java:299) ~[hive-exec-3.1.3000.7.1.7.0-551.jar:3.1.3000.7.1.7.0-551]

          at org.apache.hadoop.hive.ql.exec.tez.TezSessionPoolSession.open(TezSessionPoolSession.java:106) ~[hive-exec-3.1.3000.7.1.7.0-551.jar:3.1.3000.7.1.7.0-551] 

 

Any help appreciated.

 

 

 

 

 

3 REPLIES 3

avatar
Contributor

Can you make sure that Hiveserver2 is installed under Hive_on_Tez and not under Hive ?

 

Most probably the tez libraries are not defined under hive configurations 

 

1- try adding this property "tez.lib.uris"  in Hive on Tez and Hive services

 

   - Cloudera Manager -> Hive on Tez -> Configurations ->  "Hive Service Advanced Configuration Snippet (Safety Valve) for hive-site.xml"

      tez.lib.uris=/user/tez/<version>/tez.tar.gz

 

      ## Where (/user/tez/<version>/tez.tar.gz) is an HDFS location.

 

   - Cloudera Manager -> Hive -> Configurations ->  "Hive Service Advanced Configuration Snippet (Safety Valve) for hive-site.xml"

     tez.lib.uris=/user/tez/<version>/tez.tar.gz

 

Also make sure tez client is installed on all the edge nodes and the file exists on HDFS

 

2 - If you don't find the file on HDFS do the following

   - Cloudera Manager -> Tez -> Actions -> "Upload Tez tar file to HDFS"

avatar
Explorer

Hi @udeshmukh ,

Above mentioned solution doesn't work for me as the things are in place. Please suggest anything else.

Thanks,
MR_KD

avatar
Community Manager

@MR_KD As this is an older post, you would have a better chance of receiving a resolution by starting a new thread. This will also be an opportunity to provide details specific to your environment that could aid others in assisting you with a more accurate answer to your question. You can link this thread as a reference in your new post. Thanks.


Regards,

Diana Torres,
Senior Community Moderator


Was your question answered? Make sure to mark the answer as the accepted solution.
If you find a reply useful, say thanks by clicking on the thumbs up button.
Learn more about the Cloudera Community: